Tolerance Settings in Rhino Mac

Does anyone know how to adjust the tolerance settings in Rhino for Mac? I keep getting unwanted results that are inaccurate. I updated Rhino, and my models seem to “self adjust”. Attached is an example. I tried to Boolean Union these two solid forms, but they changed drastically. The same happens when I trie to split the objects. Does this have to do with tolerances?

Before Boolean Union

After Boolean Union (Unwanted Result)

Could you post that file?

Boolean Tolerance Issue.3dm (119.1 KB)

The original file is confidential to my company, but I recreated this part, and it’s doing the same when I try to boolean union.

Hi Bo - the document absolute tolerance is set in File > Settings > Units page. Ideally this is set up before you start the model, as in a template file. Should be .001 max, here. More info here:


I would say that’s a tolerance issue, yes. Your tolerance is at 0.01 units and the bottom of the cylinder is 0.01 units from the bottom edge of the box. Your smallest feature (smallest thing you’ll measure) should be at least one order of magnitude larger than the tolerance.

Change your tolerances where Pascal pointed at… :wink:

Hey thanks! Very grateful for the feedback. Will this fix the filleting issue i’ve been having with curves?
see post here: Issues with Fillet command for Curves

yeah, probably.

that said, it’s just a guess… you’ll generally get more accurate and quicker help around here for “why is my model acting weird” type of questions…

[edit]… uh… i forgot the rest of the sentence which should be → If you post an example .3dm