Sweep from Polyline creates broken chunks along curve

I’m trying to get this rectangle to sweep this curve. Its currently a poly line, as it was generated from intersecting a mesh and a plane. can someone explain what is happening, and even better, any thoughts on how to fix?


Sweep test.gh (9.8 MB)

changing the Sweep kink miter type to None probably helps understanding what’s going on:

Yes, I tried this and got the same result as you’re showing in the screen shot. The sweep command seems to be copying and orienting a small extruded rectangle along the curve I want to sweep.

Maybe this is because this was generated from a mesh intersection? I’ve tried to simplify, and fit a curve to the original, with no luck so far.

I rebuilt your curves and tried Extrude Along but I’m not sure about the result on the extreme curves in the second half of your object.

The low end looks nice:

extrude_along.gh (3.3 MB)

1 Like

It looks perfect. All these shapes will be laser cut, so extreme is not too bad.

If you have time, could you explain the process you chose to clean up these lines?

1 Like

You can see it in the GH defnition…

I don’t have the file open anymore but I think I eliminated not so significant points and then interpolated a new curve. Fixing curves is always a bit of a trial and error.

1 Like