Sweep 1 on spatial curve fail

Hi guys,

Recently I have been working on a project that requires me to make sweep 1 tails of some 200100/100100 rectangle profile into a serious of spatial curves.

these rail curves themselves I make them via pufferfish, basically these are straight sections of top and bottom edges using blendcrv to get the round corner and then using tweencrv to make the full sets.

I preset those said straight sections in RHINO and by adjusting the endpoints in Rhino I can get the desire shape of the whole design.

I have been able to create these curves with some effort (which I will attach the gh file below.) but when it comes to making these curves into a solid shape comes the trouble.

At first I tried to use prep frame on these curves and then make the 200*100 rectangle sections align to the normal direction of the curves then using sweep 1 to create the rails.

I tried these on the top 2 parts which they are opened polycrvs, there was some hiccups where in grasshopper the sweep1 didn’t work and I had to bake the sections and do the sweep1 action in rhino.

But the lower 2 parts which they are closed polycrvs I tried so many times in both grasshopper and in Rhino where I couldn’t make the sweep1 work on the whole curve. Then I tried to sweep them by sections, I split the curves into segments and sweep them 1 by 1. But there are certain parts it just won’t work.

Here for instance, the round corner sweep1 is unsuccessful.

I am really out of options. I hope someone can enlighten me.

Thanks alot.

Ps: for some reason I can’t seem to upload the files via forum so I am putting this google drive link here, sorry for the trouble.