Sweep Curve


(Valerio Romito) #1

The sweep seems to work correctly with the square section curve, when the section becomes rectangular the error is out, so we understand that the planes do not all rotate in the same way.
How can I solve?

Sweep_Sections_Perpendicular_a_Curve.gh (19.7 KB)


(Michael Pryor) #2

Seems to work fine here until I go past 4 in the rectangles y. I think it fails at the point where there is too much self intersection. You could add many more curve frames and use loft instead.


(Valerio Romito) #3

The problem remains with different values of x and y


(Michael Pryor) #4

Can you post a screenshot of the issue? Seems fine here.


(Valerio Romito) #5

I think I’ve solved it, yes with the loft it’s even faster … I just need to check the angle of rotation of the section around the curve … any suggestions?

Loft_Sections_Perpendicular_a_Curve.gh (17.8 KB)


(Valerio Romito) #6

I thought I had solved it, but what I did in Rhino does not succeed in Grasshopper.
I selected the base curve n°1 as a rail and with the sections n°2 I performed Sweep1 with the parameter “Roadlike Top”, obtained the surface I extracted the edges, curve n°3 and 4 with which I made the Sweep2 with the sections n°5 “Maintain height” parameter.
Sections 2 and 5 must be in a planar position.

Rhino_geometries.gh (28.4 KB)


(Valerio Romito) #7

I managed to get what I wanted, I just have to put the various elements in order