"Sweep 2 Rails" gets two hits in two different files


#1


The first object is a piece of a boat that I’m drawing, done with the command “sweeo 2 rails.” This surface is not continuous, it has a cut on the curve. I have tried all the possible variations in executing the command, but the result is always the same
The object “edge cockpit” is obtained by copying the two rails and the two sections and pasting them into a new file. This surface has no discontinuities instead.
I do not understand the difference in the outcome.

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-07-14 (518)
OS X version: Versione 10.9.4 (Build 13E28)

Plug-ins
None

Hardware information

Computer hardware
Hardware model: MacBookPro6,1
Processor: Intel Core i5 CPU M 540 @ 2.53GHz
Memory: 4 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 330M 512 MB
Memory: 512 MB
Screen size: 1920 x 1200
Displays: LCD colori

Third party kernel extensions
com.sophos.nke.swi (9.0.53)
com.sophos.kext.sav (9.0.61)

USB devices
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller
Primax Electronics: Apple Optical USB Mouse
Apple Computer, Inc.: IR Receiver
Apple Inc.: Built-in iSight

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-8.24.15 310.90.9.05f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 8192 x 8192
Z-buffer depth: 24 bits
Maximum viewport size: 8192 x 8192

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: Nessuno
Anisotropic filtering: Nessuno


(John Brock) #2

It looks like your rail curves aren’t smooth. They appear to have kinks in them so Rhino is doing the best it can with poor input curves.

Can you please attach a 3dm file with the curves you’re using so we can have a look?

Thanks


#3

Hello John,
do not laugh at my project, I try to draw a boat for hobby; I normally design houses with Archicad.
Thanks
BARCA5.3dm (4.2 MB)

bordo pozzetto.3dm (2.65 MB)


(Pascal Golay) #4

Hi Giuseppe- with this set-up, I’d use the ‘Add slash’ function as in the attached file to force the sweep to line up to the corner curves. You could also do it in three parts, also included.

bordo pozzetto_PG.3dm (2.2 MB)

-Pascal


(John Brock) #5

Hi
The first thing I noticed when I inspected your curves, is they don’t have the same number of control points distributed the same way to define the same feature. Turn on control points (F10) to see them. The two profile curves look pretty good. The one on the right (positive X direction) is perfect. The left one just has a few extra points. Since the rail curves have a simpler shape then the profile curves, they should have less points.
Here are the points on your curves:

Here are the curves after I cleaned them up and made the points match better:

I did three sweeps instead of 1 to get cleaner surfaces:

Here’s a shaded view:


#6

Thanks John,

I learned a new thing.
Is there a command to clean the curves or you must do that by hand?


(John Brock) #7

There are a variety of commands. In this case I used Rebuild, RebuildNonUniform, Split and I manually deleted a few points too. There is no magic “CleanUpMyCurvesSoThisWillWorkBetter” command unfortunately.


#8

Ok John,

helpful and pleasant.


#9

I thought I had figured out how it works, I have redrawn the lines and curves so that they are as simple as possible and I checked that had the same control points distributed in the same proportions; but the result is worse than before.
Where am I wrong?………
prova sweep2.3dm (2.15 MB)


#10

I thought I had figured out how it works, I have redrawn the lines and curves so that they are as simple as possible and I checked that had the same control points distributed in the same proportions; but the result is worse than before.
Where am I wrong?………
prova sweep2.3dm (2.15 MB)


(Pascal Golay) #11

Hi Giuseppe- just in case - did you see the file attached to my post above? I think the simple way out is to use ‘Add Slash’ in Sweep2. You might want to SimplifyCrv the rails beforehand as well.

-Pascal


(John Brock) #12

Pascal is right, this is what Add slash is for. I used the older, less elegant technique of doing three separate sweeps and Joining them


#13

Hi Pascal, Hi John,
Sorry for my English which is by google-translate.
I use Rhino Italian and I think “insert Slash” is the same command: Edit> Control Points> Insert point of discontinuity. "
I have seen the file “pozzetto_PG.3dm edge”, but the result is the same as mine “bordo_pozzetto.3dm”, where I had not entered “slash”.
I tried to insert points of discontinuity in the file “BARCA5.3dm”, but the result is still wrong.
I remind you that my question was, why did the same curves with the same command in the file “BARCA5.3dm” give a wrong result, while in the file “bordo_pozzetto.3dm” give a correct result?
The first is the entire project, the second has only the lines concerned.
However, following the advice of John, by running the command three times, I get a good result also apparent in the file “BARCA5.3dm,” although do not know how to interpret the analysis of the zebras.

Thank you for your patience and availability.