Sweep 1 question - move curve and sweep fails

Clearly I am ignorant about some concept in sweep. I have frequently had issues with set of rail/profiles fail in grasshopper but work in rhino. Here is an example extracted from a larger definition. If the failing curve is flipped then the sweep works - but then the curves are in different directions. What adjustment does the rhino command make?sweep1Question.gh (15.3 KB)

My first thought on reading your question was that the pick order of the profiles might be the issue. In GH this translates into the order the profiles are fed into the component. This seemed fine though in this case but it might be useful in troubleshooting others later. The solution for the Sweep that was failing here was to flip the direction of the rail curve with a flip curve component like this…

I’m not sure yet why this is needed in the top version of the sweep but not the bottom but it works so I thought I’d pass it on.

I know that flipping makes it work - I need to know why so I can automate the process. At the moment as I explore shape options the sweep starts/stops working - though usually if I add (or remove) a “flip” it works again. Gotta be a reason - in general I suspect that the rhino sweep command does a number of things under the hood…

I tried to find an issue, but didn’t get anywhere. It’s logged now under RH-43414 so someone else can look into it.

I have oft had issues with sweep (both 1 and 2). I tried invoking the sweep method directly from python - which sometimes behaved differently than the component. The current project is the first time I have had any quantifiable attribute (rail direction). Hope the person who knows what is going on under the hood will shed some light.