SOS New update 7.14.21348.13001 broke the Grasshopper tool SweepTwoRail!

New update 7.14.21348.13001 broke the Grasshopper tool Sweep2(SweepTwoRail)

Hi Taraskydon

I’m having the same problem.
After updating, Sweep2 stopped working on grasshopper.
I can confirm that there is no problem with the direction of the curve and the intersection of the curves.
But as far as I can tell, there is no problem when i use the Sweep2 command from Rhinocerous.
I suspect it is due to the different number of control points for the curve, and I also tried Rebuild, but it failed.

Sweep2.3dm (191.9 KB) (195.6 KB)

I was just about to post about this same problem, which started after I updated Rhino yesterday.

Since the Rhino command works, I guess a workaround will be to invoke a RhinoCommon command from a script? Guess it’s time for me to learn how to do that, unless someone else has it handy?

SweepTwoRail component via C # also doesn’t work. ! (10.0 KB)


I reopended RH-66617 Problem with sweep2 in grasshopper and added this topic as comment to the issue.


@taraskydon - this seem to work here using the SR14 RC. What am I missing? (4.7 KB)

– Dale

Hi @user2403,

This should be fixed in this week’s SR14 release candidate. Thanks for reporting.

– Dale


RH-66617 is fixed in Rhino 7 Service Release 14

Hi @brian, @dale, @nathanletwory, thanks for your attention on this.

I’m still having a little trouble with this Sweep2 function in GH. No matter how I flip the rails, the sweep always ends up the same.

sweep2_flip (11.9 KB)

Thank you!

This is fixed for me now, thanks to all.

I’m having problems with GH sweep2 since 7.14 in that it doesn’t generate the same result as with previous versions. I’m on a deadline and I’ll report the exact issue that I have after the deadline. Does anyone have the installer for 7.13?

See your private messages for the link.

1 Like