Sub-d To NURBS observation: No Iso-Curves

Just an observation about converting from Sub-D to NURBS:
I noticed that the resulting surfaces or polysurfaces do not show isocureves. ("Show Isocurves: is checked on under display settings.) This has not produced any issues for me, just a curiosity.

However converting a Sub-D object to a Brep component in Grasshopper and baking the node DOES produce isocurves in the resulting subsurfaces of the polysurface.
Interestingly, assigning the converted, packed Sub-D to NURBS surface or polysurface to a Grasshopper surface of brep node and baking it DOES produce isocurves in the baked object.

None of this has led to any issues for me whatsoever, just curious about whats going on under the hood of the ToNurbs command and what impact if any this may have further along in my workflow.

See attached file and images

Selecting unpacked sometimes leads to render mesh anomalies in the NURBS surface, but this is usually easily resolved by exploding the poly and, refitting surfaces to tolerance, and rejoining, or adjusting the render mesh almost always fixes it.

SUB_D 7.3dm (12.9 MB)
SUB_D (1.9 KB)

1 Like

The output of ToNurbs from a SubD does not have its “show surface isocurve” property turned on, probably because the SubD has no such property. When we try to copy properties from the SubD to the Brep, this one defaults to OFF.

I don’t know the details for Grasshopper, but it looks like it bakes Brep with their “show surface isocurve” property ON, which is maybe a better default setting.

@dalelear or @BrianJ, do you know if that should be turned ON by default in SubD ToNurbs as well?

1 Like

One advantage of the face packing option over that method is that we are able to remove up to two rows of CVs at every smooth edge, without changing the surface’s shape, in ToNurbs. If what you are after is manual control of the face packs, then that is indeed the best solution for now.

Please make a separate topic for this request, and give it the tag “extendsrf”. It sounds like it could be useful and we might be able to implement it.

I assumed you had it (ToNURBS) set to disable the isocurves per object due to the density and to make it more clear where the edges were. I actually like it this way but knew about the per object setting. I can see how it might be confusing if you didn’t though. I’m fine with it either way.

1 Like

This is tracked here:
The “show surface isocurve” value will honor the app setting for that when creating a Brep from a SubD.

Thank you for the reply. Had never noticed this feature under object properties.

Thanks, makes perfect sense to me know. I was thinking is was a display setting issue and hadn’t noticed isocurve density in the object properties.

RH-60811 is fixed in the latest BETA