STEP Export Blocks Behaviour Change?

I exported some STEP files today - all watertight polysurfaces. None of them were defined as Blocks within the Rhino file (I rarely use Blocks).

I always import back into a clean Rhino file before sending to make sure the export is good. Today I noticed that they were coming in as Blocks, and none of the polysurface edges were joined. I don’t recall seeing this before. Is this behaviour as expected or have I accidently changed something without realising?


Sounds like you unchecked the import options box for joining.


Thanks, Chuck. Don’t I feel stupid - I never mess about with the STEP options because it always works so reliably. At the weekend I had a bad file from Pro_Engineer and for the first time in, probably ten years, fiddled with the STEP options. It was exactly as you suggested - I’d unchecked the Join Surfaces. Obvious now.

It was the Block thing that threw me - for some reason without the join option the files come in as blocks. That’s my excuse anyway!

Thanks very much for your help.

I’m glad that’s what it was. There have been some changes to the import dialog recently that should not have had any chance to cause problems, but you can never be 100% sure.