Split command error


I have only been using rhino for a year now, so i’d say i am still fairly new to the software. I am trying to draw up a pod that goes under a boat to attach the propeller to. I played around using a standard NACA airwing profile and did a bit of revolving and scaling to it and i am happy with the way it turned out. I would now like to split the thing in half and try to design mounting points and further bits on the inside of it, but creating a surface through the middle, then “split” throws an error i don’t understand. I have tried searching around on the forums but couldn’t find a topic where the problem was solved (in a way i understand, haha). Can someone point me to what i’m doing wrong?

pod_needhelpsplitting.3dm (198.7 KB)

Hello - this is a bug - it should split. You can work around it in a couple of ways -

  1. Use the Isocurve option in Split, make sure the direction is set to give you a long-wise isocurve and set the ‘Int’ OSnap - snap to the intersection (easier in a wireframe viewport) of the isocurves at the top of the shape.
  2. InsertKnot, in the ‘along’ direction, using the Automatic option a couple of times, then split with the plane.

I’ll get this on the bug pile, thanks for pointing it out.
RH-61055 Split fails


1 Like