Solid model goes awry while printing


I am making a simple 3D printed door sign for a friend, see attached model.

Clayton Care_Prep_v0.2.3dm (1.0 MB)

Clayton Care_Prep_v0.2.stl (4.3 MB)

To create the model I used the following work flow:

  1. Use the Text function to create solid letters
  2. Scale to increase size of Text to fit BoundingBox, box was only to make sure model would fit on printer.
  3. Offset curves of Text to create the basic outside shape
  4. ProjectToCPlane Offset Curves to make next steps easier
  5. Used Split on the various Curves to create the final outside shape, the used Join to create a single closed curve. I then ExtrudeCurve to create a solid. Used ShowEdges to make sure no Naked or Manifold edges, all was fine, Then used SelBadObjects. All ok at this point
  6. From here I moved the Text into position to BooleanDifference. Then ran through ShowEdges and SelBadObjects again…(just habit)
  7. The nail cuts out for the back of the model, which will be used to hang it, were copied in from a different model so know they work. So BooleanDifference, ShowEdges** and SelBadObjects. Model was still ok.
  8. Before printing I always save a new version of the model and remove the layers/curves I don’t need. Then I save this file as an STL
  9. Then I tried to print… and every time I tried it has failed, see below for example:

What has added to the confusion is I have recently received a replacement printer, so have been working with the manufacturer to see if the printer was at fault i.e. checking profile, calibrations, filaments, firmware etc etc. However after a number of tests we still can’t get this model to print, but other models have printed no problem. Which makes me think the model is very flawed but I don’t know why. The only thing I didn’t do (that I can think of) was Rebuild the Offset curves, but wouldn’t have thought it would cause the print to fail.

Any ideas what is wrong? It may still be the printer, but I thought I might checked the combined brain power here as well, as this driving me nuts. :grin:



Only way to know if it’s the file or the machine would be to post both the Rhino and the STL files here so someone can take a look. --Mitch

Oops, updated to include the STL file

The Rhino model looks fine here, the STL is however different than the Rhino model - seems to have some differential scaling applied, it has a few nasty artifacts in the letter openings as well. Did you go through another program? Rhino should make a better STL than that.

Despite this, the STL you posted does check out OK here and should still print.

Here is my STL out of Rhino from your file.
Clayton Care_Prep_v0.2-msh.stl (1.1 MB)



Thanks for the super quick response.

The STL file was created in Rhino but it is odd that the scaling is different, as didn’t change that until I loaded it into Cura. Any ideas what would cause this change? For info, I am not aware that I have changed the STL settings from the Rhino default. Will admit I know little about meshes, as the vast majority of my models are not complex so haven’t really learned much about them. Maybe it is time I should…

Trying your mesh just now, as that will give me a good idea if it is the model or printer is at fault. Was going to say fingers crossed it is not the model but it is probably easier to fix than the printer… :wink:


I’m just wondering if the STL you posted is from a different version of the file? The words aren’t aligned in the same way and even a differential scaling wouldn’t cause that. The STL is also thicker in Z…


Once I have saved my prepared 3DM file all I do is Save As STL file, so there should be no difference.

For info, for the “STL Mesh Export Options” pop up the “Tolerance” is set to 0.01 millimetres. Then on the next pop up, “STL Export Options”, the File Type selected by default is “Binary” with “Export open objects” checked. Before now this hasn’t been a problem, or maybe it has but I have got away with it by chance.

Are any of my settings incorrect, and are there other functions/configurations I can check? Also what is the best way to fix nasty artefacts in Rhino, happy to watch recommended tutorials?

Update: Your mesh printed fine, so it looks like it is my STL/mesh…



These are my STL mesh settings (you need to go into detailed controls)


1 Like

@Helvetosaur Thanks for the configurations, tried them but alas they didn’t make any difference to my print.

I decided to have a proper look at the difference between the STL and 3DM model, as per your comment on the 19th. However, when I import all three models into Rhino to carry out a comparison the only model that is different is yours i.e. my STL and 3DM files match. See link:

Check.3dm (4.7 MB)

And just in case your Rhino shows something different, here is a screenshot of it:

Have to admit I am now confused, as:

  1. My model, as you say, looks fine but doesn’t print
  2. Your initial analysis showed that there was a difference in scaling on my STL and 3DM files, but I can’t see it at my end.
  3. You created a model from my 3DM file and it works fine
  4. I have amended my settings to your details, and no difference again to the quality of the print.

Could there be anything else wrong with my software that I should check, as know the issue is at my end? Or am I doing anything else wrong? I have had problems with prints before but have always assumed it was the printer, and maybe in some cases it wasn’t.



hey Laura.

you might have a better outcome if you mesh first in rhino then export the mesh as .STL …
there’s a command named Mesh.

so run it on your volume then export the newly created mesh.

any better?

1 Like

@jeff_hammond Mesh worked, and will use every time from now on. Thank you.

Also resolved the size issue, as had loaded an earlier file by mistake and it was a slightly different size. Doh. Sorry @Helvetosaur hope I didn’t waste too your time, but well spotted and thanks for your help.


@laura_vw I always mesh and then export to STL as @jeff_hammond suggested before sending to my printer.

Even with items that come up as a closed solid valid polysurface I will get a bad mesh due to my poor geometry from time to time.

Another good command to get to know is MeshRepair. Run it after you Mesh. It will let you know if there are any problems with your mesh and then run you through an attempt to repair process if there are any problems.

Takes a bit to get your head around the MeshRepair interface but once you do it is a great tool IMO.

Often rather than repair a mesh I will go back and fix the polysurface based on the area giving me errors in the mesh check and then re mesh.

I generally go straight to MeshRepair as it does Check on the mesh first anyway. If no problems I just exit. HTH


now im just throwing this out there. i have 3 3d printers that run 16-20 hrs a day for 3 years now. in all the models i have made with rhino, i have never exported one to an stl and had a bad mesh with errors. i never meshed prior to export. i always export selected, choose stl and its as simple as that. assuming everything was modeled correctly and nothing was invalid or had naked edges or anything like that then your mesh should be good to go. if you have doubt on a model then go here and upload it to the cloud repair svc. it works really well. it will pretty much give you back an error free model for printing. cura should have no problem with it at that point. if it does then its simply profile settings for you printer. 3d printing has a big learning curve. its no different that running an cnc mill in a machine shop. every setting has to be just right and while the slicer developers would like you to think many settings are auto or can give you click to print experience, that is complete bs. every spool you run though the machine needs to be tuned in to print properly

ok i looked at a couple of the stl’s posted. laura, i ran your stl through netfabb and it had no errors. i put it in my slicer and looked closely. your main issue is that the stl is not flat on the world plane when you export it. basically your slicer is dropping it on the build platform and the side where the “C” in clayton is is down on the table but the rest of the model is not and its being printed in mid air. now mitch’s stl that he did is correct and set flat. the bottom of the model is basically sitting 100% flat down on the world plane which will allow the model to sit on the build table in your slicer correctly.

@jimc Yep, I noticed that yesterday too, and agree that was a problem. However the original model was flat (I think) and Cura wouldn’t recognise it, even though the file looked fine which was why I raised the original query. During this time I created a 2nd model, that ended up being squiffy as I rushed it (probably happened while using Scale* and selecting Quad rather than End), and hadn’t carried out all the checks to make sure it was flat. Like you I usually save directly to STL but in this case, with the correct model (i.e. the first one), the Mesh function worked well.

Absolutely agree that 3D modelling/printing is a huge learning curve, as soon as you become even slightly confident in something it will remind you (and not in a subtle way) there you still have a huge amount to learn. :joy:

New to stl file creation and not sure if this is relevant to this thread, but I did notice a big difference in “export selected” as opposed to “save as” when converting .3dm to .stl. Not sure why?

Export (selected) does exactly what it says: exports the selected objects. If nothing is selected, it asks you to select some. SaveAs exports the entire file.


THANKYOU! This did it for me too.

All the best,