So many naked edges

Hi! I cannot create closed solid polysurface from mold model. What about general methodology for fixing this model? Thanx!

top_strap_mould.stp (8.5 MB)

You don’t need the show naked edges command to highlight the problem, you can see it with the naked eye:

My advice would be to use the DupFaceBorder command on the main surface and extrude the shapes again. Use the correct fillet size along the bottom edge.

That’s going to be much quicker than trying to correct what you already have.

Just out of curiosity, why did you post an .stp rather than a .3dm?

Also, the geometry is control point heavy. Unless there is a reason to keep the shape 100% the same and not 99.95% the same I’d Rebuild the curves to make them uniform:


Thank you for answer. I shall use it. Originally this model designed in Siemens NX. But NX dont export in *3dm. I use saving in *.stp for importing in Rhino.

The .stp file does not contain a solid entity. It has 358 separate surface entities which, apparently, NX did not recognize as coming from a solid model. Possibly (I’m not very familiar with NX) there is an option in NX to export as surfaces rather than shells. If so, don’t use it and maybe you will get a better result.