Single surfaces of closed polysurface not visible


I have an issue with some surfaces being invisible. I can’t reproduce this but whenever I build polysurfaces (mostly extruded curves + boolean union/difference) some surfaces are not visible or only fragments are visible. Happens in all display modes and also make2d does not show the surfaces

There are no bad objects in the model. The polysurfaces are all closed. I tried exploding them and replacing the invisible surfaces but neither cap was working nor could I just draw a new surface that worked.

I just upgraded from Rhino5 to Rhino7 and I have never experienced this issue in Rhino5. Also when I export the model to Rhino5 I can fix the surfaces with cap.

Does someone have an idea how to solve this problem? Could it be a problem with the graphics card?

I am using an i7-7700HQ + Quadro M1200

Invisible Surfaces.3dm (362.8 KB)

1 Like

Hello- the narrow strip along the ‘back’ of all those invisibles is .01 wide - that is the same as the file tolerance. My guess is that is messing with the meshing of this object. You can ‘fix’ the meshing by extractSrf on one of the invisibles and then joining it back in but I would not model surfaces that are any smaller than 10X the file tolerance.



Has there been any development on this? I’m having this exact problem in Rhino 8. Extracting the invisible surfaces and re-joining them does work- but it’s not practical in my case where I potentially have hundreds of affected elements. I don’t think I’m experiencing any unit or tolerance issues, and my geometry is not particularly small or complicated.


closed polysrf - invisible faces.3dm (1.3 MB)

@mgb228 the “invisible” surfaces have inward facing normals. Select the polysurface, run the _Dir command and check the arrows (facing inward in this case).

This corrects the directions of the face normals. If you have hundreds of elements like this, you need to change the process you’re using to create them.