SimLab VR plugin for Rhino

Glad to announce release of SimLab VR plugin for Rhino, simple plugin that works from inside Rhino allowing the user to share models

Rhino models can be viewed on Windows/Mac, HTC Vive, Rift S.
They can be shared as a link in email.
Models can be viewed on Oculus Quest, Pico, iOS and Android using the free VR Viewer.

Details about the plugin can be found here.

Looking forward to answer any questions you may have.

Get your free trial here.


Hi @Ashraf
Really looking forward to trying this out, hopefully I’ll find the time next week!

1 Like

Hi @Ashraf
The plugin works flawlessly with the first couple of simple tests - well done. The first question (of many, probably) is that I notice that there are no shadows when running my Quest2 untethered, whereas I get neat shadows when running it via the link cable - eg. when turning on the sun. Is that simply a limitation of the SimLab VR viewer on the Quest platform (or perhaps rather a limitation of the Quest hardware) or is it something that can be turned on/off?
TIA, Jakob

When running via link cable, you are using the PC version of the viewer, which utilizes the PC video card. That is why you get advanced shadows and materials. in Stand Alone mode Quest uses its own hardware, which is less powerful, we turned off shadows by default to allow it to run larger models for the user.

This is something we can revisit, allowing users to turn it on or off based on the model size.

Glad to know your testing is going well.

Yes, please :slight_smile: When dealing with simple models (and we do a lot of really simple mock-ups of eg. hotel rooms and shop interiors) it would be cool to have the option of turning it on.


Hi @Ashraf
Wasn’t sure if you want bug reports here or in a separate thread, but here are my observations after spending a couple of hours time with the plugin yesteday afternoon:

  • Starting point doesn’t respect dummy’s rotation, only position.
  • When the SimLab Viewer dummy is created, the last layer (the layer called “simlabviewerstart_7”) is created outside of the folder hierachy of the other layers.
  • How do you control the direction of the spray effect? It doesn’t seem to respond to rotation at all, no matter if applied to a single surface or polysurface.
  • Mapping materials via SimLab VR settings (eg. replacing a material with a specified glass or metal) is not working at all.
  • Mapping lights via SimLab VR settings not working at all.
  • Mapping geometry via SimLab VR settings has no interface - there’s just a black box and nothing happens when you click it.
  • Rhino material types (plastic, glass, metal) and parameters (reflection, roughness etc) not converted - only textures go through. Also no opacity maps, which would be nice.
  • It would be nice if the settings for the suns position could be taken directly from the Rhino sun.
  • Also, it would be nice if the sun settings in the plugin and viewer were the same. In the plugins settings it’s in degrees (0-90° and 0-360°, in the viewer it’s 0-100%). I think degrees is the most logical.

Other than that, the actual conversion of the geometry and the viewer seems to be working fine, both in desktop, tethered VR and standalone mode :slight_smile: If you can get the material conversion to work better, it really is a one-click operation.


We are truly thankful for the feedback, I will discuss it with developers soon.

I guess you got the idea of the plugin, this plugin was designed for single click (Rhino to VR) or (Rhino to Quest) for more advanced VR experiences we have SimLab VR Studio.

But the goal it to make very easy to view models from Rhino in VR very quickly.

1 Like


Based on your feedback we enabled shadows on Quest, Pico, Android, and iOS devices

Steps the shown here


1 Like

Hi @Ashraf
Really cool news! Can’t wait to test it :smiley:
Thanks a lot!

great news!

Is there a way to adjust the eye level when viewing the models or is there a way to see what the default height is? It feels a little too short for me.

On Desktop the default height is 1.8 meter
On VR the height should automatically adjust based on user height.
What hardware are you using?

That makes sense as I was swiveling in an office chair when viewing the scene.

One more question is how do I remove or replace a file that I uploaded?

edit: I’m using an Meta Quest 2

Select the model you want to delete, then click the delete icon , right side panel (highlighted in red in the attached image)

Hi @Ashraf

I enabled High quality shadows for my Rhino model, however, when viewing it in VR, a weird effect occurs where it’s like the shadows move as I move my head around.

I will check it on quest and update you on that

1 Like

It seems there was an issue of quest, it was updated in the quest store.

Now shadow should work fine with the latest build that was just updated to the store

1 Like

Thank you—That is some quality service!

Do you think there could ever be an option to allow ambient shadows on the quest? Similar to the render view you get in Rhino.

Still on Quest and Mobile you do not get the full power a video card has on a PC.

But with new updates of unreal engine and SimLab Viewer on quest, we can improve the visual quality.

1 Like

I’m trying out this… anyone know why their “start character” looks like this?

It’s like 7 nested layers (two top layers) and several separate objects… it’s not even a block with a properly set basepoint…

EDIT: OMG, the performance is absolutely atrocious! :clown_face: And it doesn’t pick up Rhino rectangle lights. Forget I asked, this is getting uninstalled immediately.