Shell does not work: usually problems with Extrude Tapered


#1

After several versions of Rhino, I wanted Rhino 6 to work in this kind of situation.
Extrudes Tapered generate triangular surfaces that do not allow the shell command to succeed.

It would be a surprise that these kinds of examples would be solved, because rebuilding all the surfaces is a very expensive job for the user: a waste of time!
Shelling not work.3dm (340.6 KB)

(Rhino is a powerful tool, but often, it drags from version to version known issues not resolved, or partially solved.
In my opinion, it is more important that Rhino succeeds in performing such (banal) modeling operations, which will surprise you with crazy renderings or views!).


(Nathan 'jesterKing' Letwory) #2

If you shell right after you have extruded the shelling seems to work fine.


#3

I tried with the last wip. A shell of 0.2, for example, but to me returns the shell message is not solid… strange…
(I also tried to decrease the tolerance), nothing to do …


(Nathan 'jesterKing' Letwory) #4

Sorry, I forgot to mention I set Corners = Round.

I imagine that with Corners = Smooth you’d get even better results.


#5

We understand: my example does not work! Useless to turn around.
Developers give yourself a move!