Shaded vs Rendered: Depth of curves and dims displayed different?

curious why my rendered view shows the dims and curves at the correct display depth but shaded shows them behind the objects?

is there a setting for this in shaded view?

I’m not getting those results here - so either there is a setting for such or something else is going on. I put my money on the latter. :wink:
Is there a clipping plane involved in this? I tried both with and without but …
GPU make and driver date?

no clipping plane involved. ;-/

thank you for the reply an scren grab so i know that there is something wrong on my end and it’s not a setting.