Script that works fine in Rhino 5 doesn't work in Matrix

matrix

(Declan Halpin) #1

Hi all,

As the title implies, I’ve written a script that runs fine in Rhino 5 but I get an error in Matrix 8. Unfortunately I cannot share the script here, but I’m hoping some experience scripters might be able to help me troubleshoot nonetheless.

I am basically importing a layout with various layers and moving objects to those layers. My initial (Rhino) troubleshooting had the same error, but I got it resolved. There was a discrepancy between the imported layout layer names and the target (scripted) layer names. I have triple checked that, and it all matches. And again, if I run the script side-by-side in Rhino, and step through the code, it only fails in Matrix.

Is there something weird about Rhino.ObjectsByLayer() or other VB functions in Matrix that I should know about?


#2

Nope


(Declan Halpin) #3

HA! I figured it out! Completely coincidentally (I was looking for something else). In Rhino Options/Files there’s an option to import full paths for imported files, and Matrix defaults to “Use Existing…” I changed to the other option and it works as expected now. :slight_smile: