Save Area to PDF

pdf
grasshopper
unhandled
#1

Hi,

Is there any solution to save the highlighted area with grasshopper into a specific folder as PDF ?

I tried Elefront’s Export component, but it freezes my Rhino.


Draw.dxf (171.8 KB)
area.gh (6.2 KB)

Thank you

(Rickson) #2

Are you looking to print from Grasshopper?

I’m not sure how the Elefront to PDF works actually. Works great for DWG ect.

I use an old plugin from Fabtools to generate layouts in Rhino. It will generate layouts from boundaries, which can then be printed all out once.

#3

Yes I’d like to print from Grasshopper

(Rickson) #4

re-area.gh (9.2 KB)

The component needs Rhino ID’s (baked) before exporting, each one in its own branch (this is one branch)

#5

It creates a 0kb PDF file :frowning:

(Rickson) #6

Try to change the path to a different location. Mine doesn’t work on the C:\ due to permissions – that was just an example. If i path to my D:\ drive it works.

(Rickson) #7

Regardless you have to bake everything first. So I do a old autocad type setup.

Bake Plan/Elevations/Sections/Details to different files. Use worksessions to reference into Sheet files, where the border is in “model space”, using Layout Manager to generate the layouts. Print all layouts at once to PDF.

#8

i changed the location, still 0kb

(Rickson) #9

Is it pulling up the PDF Export dialog window? It might be behind your current windows. Alt-tab perhaps?

What is your intended workflow?

#10

Everything is baked, I uploaded a .dxf file that’s what I Want to print to PDF from GH

This should be a result

Result.pdf (5.2 KB)

(Rickson) #11

Thats the only method i am aware of that Exports PDF from GH.

Its not a workflow i use, although i might try again.

(Rickson) #12

I was able to print out 97 - 36x48 sheets. Only thing to figure out is the default settings export pdf printer settings and its good to go.

#13

Hi Petrik, did you ever resolve this problem? I am experiencing something like what you describe when attempting to export a PDF using the Elefront Export component. When I activate the component the rhino command line reads “Save (Go Setup Preview)”

I have followed the steps described by Rickson.

Thanks