Run Python script on startup

Hi all,

How can I run a python script on startup from the command line. I tried this:

rhino.exe  /runscript="_RunPythonScript D:/"


rhino.exe /runscript="D:/"

but neither work…


I think I found it.

rhino.exe  /runscript="_-RunPythonScript D:/"

Also, this skips splash screen and the question about units:

rhino.exe /nosplash /notemplate  /runscript="_-RunPythonScript D:/"


I can’t get something similar working with Rhino5

Paste this in the command line and the python the script runs fine

_-RunPythonScript C:/Users/IEUser/Desktop/rhino/

with this command from a bash shell

"C:/Program Files/Rhinoceros 5 (64-bit)/System/Rhino.exe" /nosplash /runscript="_-RunPythonScript C:/Users/IEUser/Desktop/rhino/", "./base.3dm"

rhino start, opens ./base.3dm but the python script isn’t run.

must be an escape issue or syntaxery magic thing…

"C:/Program Files/Rhinoceros 5 (64-bit)/System/Rhino.exe" /nosplash /notemplate /runscript='_-Exit'

It seems the runscript argument is not evaluated.
I should add that i’m using an evaluation version.

edit: I found out that the above command does work in the ‘command prompt’ of windows, but NOT in the ‘cygwin bash shell’, nor in the ‘PowerShell’. I think this is an important piece of the puzzle. unfortunatly I don’t understand either shells enough to see why the runscript argument wouldn’t be passed (notemplete or nosplash work fine…)

Hope someone knows what this can be