RhinoPython Vscode

Hey all,
I have successfully installed the Rhinopyhton in both vsCode and in the system. However, when I typed in the python file, there is no autocomplete. Can’t import any rhino nor any syntax from rhino.
I have followed every steps from the link below. Does anyone knows how to fix it?

// disable certain pylint messages
"python.linting.pylintArgs": [
    "--errors-only",
    "--disable=E0001",
    "--disable=E0401",
],
// python autocomplete extra path
"python.autoComplete.extraPaths": [
    "C:\\Program Files\\Common Files\\McNeel\\Rhinoceros\\7.0\\Plug-ins\\CodeListener (8c4235b6-64bc-4508-9166-bef8aa151085)\\0.1.7.0\\AutoComplete",
    "C:\\Users\\User\\AppData\\Roaming\\McNeel\\Rhinoceros\\7.0\\Plug-ins\\IronPython (814d908a-e25c-493d-97e9-ee3861957f49)\\settings\\lib",
    "C:\\Program Files\\Rhino 7\\Plug-ins\\IronPython\\Lib",
    "C:\\Users\\User\\AppData\\Roaming\\McNeel\\Rhinoceros\\7.0\\scripts",
    "C:\\Users\\User\\ladybug_tools\\python\\Lib\\site-packages",
],

// enable new language server. THIS IS EXTREMELY IMPORTANT TO HAVE FAST AUTOCOMPLETE!!
"python.jediEnabled": false,

// Enable/Disable rhinopython
"RhinoPython.Enabled": true,
// True if you want to reset script engine every time you send code, otherwise False
"RhinoPython.ResetAndRun": true,
"window.zoomLevel": 1
}



image

It’s import Rhino with a capital R.

I tried capitalized R, still not working. It doesn’t load any rhino library.
image

Hi,

To have autocomplete available, you can install Rhino-stubs:

HTH
-Willem