RhinoCommon.dll missing on VM


#1

Edit: Found it. manually. But why doesn’t Win10 search find such a file? Unbeliveable…)

I installed VS 2015 on a VMware machine and the GrassHopper templates. The GH template in VS asks about a path to RhinoCommon.dll but I find no RhinoCommon.dll on the VM (of course) but not my regular machine either (which has Rhino installed)

I downloaded RhinoCommonWizards.msi but that doesn’t contain any RhinoCommon.dll either.

So how do I fix this?

// Rolf


(David Rutten) #2

If you’re only concerned with referencing rhinocommon.dll in your VS project, you can just copy the dll (and don’t forget rhinocommon.xml) onto the other machine. The dll won’t run without Rhino, but you will still be able to compile against it just fine.


#3

Yup, that’d be enough, thanks. Perhaps I can make a symlink from the VM to the c:\program… folder.


Edit: OK, so it asks also for a Rhino path for debugging. Is a regular single user license valid for I installing another Rhino instance on a VM?

// Rolf


#4

I highly recommend Everything for searching files on Windows. It’s insanely fast!


#5

Hi Anders,
I use AgentRansack (and also Everything resting in my install folder), but I think I will give Everything another chance.

// Rolf


(David Rutten) #6

Yes, you may install as many copies as you like. Licenses only limit on how many different OS user accounts you are allowed to run Rhino simultaneously.


#7

@piac,
Unfortunately I get the following message in VS when trying to create a new GH Component using the GH Template:

I guess I need to manually enter some paths somewhere… or does the template assume that Rhino is installed on the VM (I see the word “AutomationObject” in the message).

// Rolf


(Giulio Piacentino) #9

Hi @RIL

this seems to be a bug in the new wizards and should be fixed. RH-39662.
In the meantime, please run the wizard on a machine where Rhino and Grasshopper are installed. Thanks!

Giulio

Giulio Piacentino
for Robert McNeel & Associates
giulio@mcneel.com


#10

I tried using symlinks to the host machine, but trying to be too smart doesn’t always pay back …

But no problem, I’ll install Rhino on the VM as well.

// Rolf


#11

Now I have installed Rhino on the VM, and reinstalled the GrassHopper Template, but still the same problem. The (GHTemplate) install log says (the row marked with * drew my attention) :

2017-06-07 16:33:53 - Searching for applicable products...
2017-06-07 16:33:53 - Found installed product - Microsoft Visual Studio Community 2015
*2017-06-07 16:33:57 - The extension with ID 'DAD17ACF-0A09-4FE0-B2F0-6E37A1C3CB03' is not installed to Microsoft Visual Studio Community 2015.
2017-06-07 16:33:57 - Found installed product - Microsoft Visual Studio 2015 Shell (Integrated)
2017-06-07 16:33:57 - Found installed product - Global Location
2017-06-07 16:34:06 - The following target products have been selected...
2017-06-07 16:34:06 - 	Microsoft Visual Studio Community 2015
2017-06-07 16:34:06 - 
2017-06-07 16:34:07 - Beginning to install extension to Microsoft Visual Studio Community 2015...
2017-06-07 16:34:07 - Install to Microsoft Visual Studio Community 2015 completed successfully. The extension has been installed to C:\USERS\ROLF\APPDATA\LOCAL\MICROSOFT\VISUALSTUDIO\14.0\EXTENSIONS\04XJIN1T.IWP\

Some crap left from earlier install attempts? Perhaps some fiddling with the Registry would do? (Installing VS on my work horse isn’t really an option since I’m running out of space)

// Rolf


(Giulio Piacentino) #12

Did you try running Rhino WIP? Is Rhino WIP starting in the VM?


#13

Yes. I also tried uninstall and reinstall GHPackage.vsix after installing Rhino, all in different combinations, but no go.

// Rolf


(Giulio Piacentino) #14

Reinstalling the wizard should not make a difference. The error happens when the wizard looks into your registry and searches for the location of the Rhino WIP install, to find RhinoCommon.


#15

I had the wrong GHPackage (Rh5) for WIP. So GHPackage for WIP works on VS2015, but not Rh5.

I have both Rhino5(x64) and WIP installed on the VM.

Will there be a fix for GHPackage5? I need to use Rhino 5 for now.

// Rolf


(Giulio Piacentino) #16

The old V5 one will not be fixed, but you should be able to use the new one with VS2015 and manually insert the location of V5 .dlls. Does it help?

I released a new version of the V6 wizard for Grasshopper, btw, to better handle your case.


#17

I can find the RhinoCommon.dll for Rhino 5 but not the GrassHopper.dll (only for WIP). Where should I point for GrassHopper.dll in Rhino5?

// Rolf


(Giulio Piacentino) #18

That .dll comes with the Grasshopper installer in V5: http://www.grasshopper3d.com/page/download-1

Giulio

Giulio Piacentino
for Robert McNeel & Associates
giulio@mcneel.com


#19

OK, now everything seems to work fine. Thanks!

// Rolf