Rhino WIP crashes on opening grasshopper file

I recently updated Rhino WIP for Windows
version from 7.0.19233.06455 to 7.0.19239.11525
and when i open grasshopper file, Rhino app crashes or shows error dialog.
dialog message is :

Unrecognized Objects:
There are three unrecognized objects in the file. Most unrecognized objects are part of a plug-in not installed on this machine. We’ve tried to harvest as much information as possible about this missing plug-in, but you will have to find and install it before this file will open correctly.

Object / Plug-in / Version / Author

End Points / ? / ? / ?
Dash Pattern / ? / ? / ?
Length / ? / ? / ?

When i click download and Install, Rhino crashes.

So for now, I downgraded to 7.0.19233.06455 version, which works well.

Please take a look and reply. Thanks.

Hi Evan - it looks like the Discourse system deleted your initial post on this topic - I’ve now restored that. - Rhino WIP crashes or shows error on opening grasshopper file

You put that first post in the Compute.rhino3d category and provided a link to a page on GitHub - was that information relevant to the crashing?

You also provided the SystemInfo for your PC. That shows that Windows 10 doesn’t find a GPU on your system. If you know what make and model GPU you have, you should try to install the latest drivers for that GPU.

Finally, if updating the drivers doesn’t help, does Rhino crash when opening any Grasshopper file at all or is it limited to a specific definition?

@wim Hi Wim,
A link to github page I pasted on the other post, was not relevant to the crash, it was my mistake.

And If you mean graphic driver, it doesn’t have any external graphic, it uses internal graphic.
(Microsoft Basic Display Adapter (Unknown) Memory: 0MB, Driver date: 6-21-2006 (M-D-Y).)
And its driver version is up to date.

For final question, it doesn’t always crash when i open grasshopper file. I can’t specify the situation.
But it is not limited to one specific file. I tried to open other files, and it crashed too.
I use several aws instance, and for some instances, even if I updated Rhino WIP to latest version which I experienced crashes, it works fine, but others don’t.

Anyway, previous version (7.0.19233.06455) doesn’t crash, so I’ll use this version until the issue is fixed before expiration date.(10.05)

But I hope this issue will be fixed ASAP. Thanks for your quick response.

Hi Evan,
Could you please download the utility that @jeff posted in the following post and follow his instructions?


Hi, Wim. @wim

I’ve attached screenshot as requested. Thanks.

Can anybody give some help about this issue?
It’s pretty urgent. If this issue will not be fixed in updated WIP version,
my servicce will not be available.

FYI, the crash is being worked on.

@nathanletwory Hi,
Thanks for the reply.
Is error dialog showing issue which I described also related to the crash??

@evan12 since the changeset causing the crash is rather large it very well could be related, but we can’t know for sure yet.

@nathanletwory Thank you for quick response!
I’ll appreciate it if I can get notified when it is fixed.

just for reminder, is this issue fixed in latest release?

It seems that the issue is fixed, but I just wanted to double check. Thanks.

Some changes were made wrt this issue yes.

@nathanletwory Thank you for confirmation. The latest version works well.