Rhino WIP (6.0.17122.11501, 17/05/02) crash switching to Raytraced with CUDA, and how to FIX

cycles

(Nathan 'jesterKing' Letwory) #1

Due to an error (probably me) the .cubin files that come with the latest Rhino WIP release (2017.05.02) are incorrect. I have already fixed the files for our build system, and hopefully @brian can update the public installer soon.

Until then if you already downloaded and installed the latest public Rhino WIP you can get the correct .cubin files and place them in the right place to ensure switching to Raytraced with a CUDA (Nvidia) card works as it should.

Please download the 7z file containing proper .cubin files from my dropbox. The contents of the 7z file should be placed in C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles\lib (you’ll see that the current files are all 1KB or smaller).


#2

I downloaded these .cubin files, but this weeks WIP is a bit weird so to say.

Using McNeel’s MtMonadnock NH environment e.g. there are almost no shadows:

And this is like high noon sun on Ridgecrest Road from hdrlabs, which also looks wrong when changing intensity:

This is Ridgecrest Road without ground plane:

And this is Ridgecrest Road WITH ground plane saved using ViewCaptureToClipboard:


On the development of rendering solutions in Rhino
(Pascal Golay) #3

Hi Marcus - as far as I can see the clipping is gone in the latest - can you check the next WIP and let us know? But Cycles response to HDR intensity, saturation, grayscale seems… wrong, as if it is not implemented yet, I’ll check.
https://mcneel.myjetbrains.com/youtrack/issue/RH-39346

-Pascal


#4

Using ViewCaptureToClipboard there is still clipping.

Yes, I had also reported that and 2 weeks ago HDRs were still turned into thumbnails:


(Nathan 'jesterKing' Letwory) #5

For skylight they are downsampled and blurred heavily. The 360° is still original size. The skylight version is samples from the one that is in either 360° slot, or custom, but honours further its settings.

Intensity, grayscale both work fine here.