Rhino file computing technical data for 10 minutes when opening

Hello everybody,

I have a relatively large rhino file (1400 Mb) which takes over 10 minutes of computing technical drawing data when opening before I’m able to use the file. It also does this everytime I open the file. I know the file is relatively big, but I have been working in the file for half a year now, and it has only started doing this recently. Up until a few days ago, the file would load almost instantly.

I have already selected and fixed all the bad objects in the file, so this is not it. Does anybody know a solution?

Kind regards,


Results of _Systeminfo:

Rhino 7 SR16 2022-3-8 (Rhino 7, 7.16.22067.13001, Git hash:master @ aa7902c94c5aa33511e60d30f82b636be43bc85f)
License type: Educational Lab License, build 2022-03-08
License details: Cloud Zoo

Windows 10.0.19044 SR0.0 or greater (Physical RAM: 15Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3060 Laptop GPU (NVidia) Memory: 6GB, Driver date: 5-4-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 512.77
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
AMD Radeon™ Graphics (AMD) Memory: 1GB, Driver date: 1-11-2022 (M-D-Y).
> Integrated accelerated graphics device with 5 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-4-2022
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Users\b-sch\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.21349.1646

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Are you opening with everything visible? Are worksessions an option?

There are some objects that are hidden. I have checked those for bad objects as well however. Could this be affecting the model in other ways?

How would I go about using the worksessions? it is an architecture project so I do need all the geometry visible in one view in order to extract images

(P.S I have also disabled loading of the enscape plugin when opening Rhino, this makes no difference)

Having most of the visible objects turned off should increase start times, ideally to work on specific areas, then turning on additional geometry when generating images.

Worksessions can be accessed by right clicking in the layer dialog or typing in worksessions in the command line.

In an architectural example you could have all the site work in one file and worksession it in when needed. Worksessions can also be saved and turned of via the layer dialog as well. The general idea here is creating smaller, workable files that don’t take 10 minutes to open.

Hi Bart -
I’d try importing the file in a completely new file with all viewports set to the wireframe display mode. The display meshes for technical display modes are never saved in the file and need to be recomputed every time the file is opened.

Hello Japhy,

I discovered it was because of a polysurface derived from an imported autocad drawing. With that layer off the file now loads in 20 seconds. I don’t know why because the imported geometry was not that complex, but I found the solution.

Thank you kindly for the help, and I will definitely use the worksessions as the project will get heavier for the next presentation.

Kind regards,


Hi Bart,

did you try to run ‘purge’, ‘clearundo’, ‘Historypurge’ and the like.

I found myself with exactely the same problem some days ago and
when I tried to find out about possible reasons for the overly long loading- and savingtimes
(my filesize was only 213 MB) I stumbled upon the ‘purge’ and ‘clear’ commands in the Rhino-forum.)

That finally worked out.

Amazingly 19.750 different materials (leagacy rhino render materials < it said)) had been assigned to my drawing elements.

I had in fact played around in the options panel, as I was wondering about a lot of meshing action being reported in the command line, though I only had 22 simple rectangular surfaces (picture frames) in my drawing - the rest being 2d-projections for the technical drawing.
In my 3d working drawing I had lots of polygons and mesh-objects, but in a final step, as soon as I won’t need the 3d-data any longer, I ‘save as’ the file as a ‘2d-edit’-version of the former 3d-file, which I of course keep for the option of further amendments But a no point in time I had consciously assigned any materials.
It seemed, as if the materials had indeed been assigned to all elements, even lines and points.
May be something similar has happened to your file as well.

Hello Wim,

Thank you for your help as well. The building was already modelled in a different file and imported into the surroundings. In both files the problem appeared so it was definitely to do with the geometry of the building. I have found the solution to the problem now.

Coming back to this, it turns out more layers were responsible so it’s not got to do with imported geometry. @Claude I will now try your solution and see if it helps.

This unfortunately didn’t work either. The strange thing is, if I turn off the layers, save the file and reopen it, it reopens in an instant. When I then turn the layers on the also turn on in an instant.

When I how turn the layers on, and then save and reopen, it takes like 10-15 minutes.

Hoi Bart -

Which display mode are you in when you turn on those layers?

Usually shaded. When transferring to heavier viewmodes like pen afterwards this still only takes about half a minute of computing time. I’ve accidentally saved again with all layers on this morning and the loading of the file has been taking 20 minutes and is still going as of now.


Hoi Bart -

We’ll need that file to be able to see what is going on here. Please use Rhino - Upload to Support to upload it and make sure to copy the URL to this thread in the comments field.

Hoi Wim,

I have uploaded the file.