Rhino export for CNC in stp / iges / sat


#1

Hi friends,

I’ve been using Rhino to produce drawings for 2D machining for three years and love it… but I now need to get something CNC cut in 3D. I actually use Rhino for Mac; but I checked and found that this problem is also true of Windows - so I’ve posted here for the larger audience.

I’ve attached my job. It’s very simple… I use Rhino 5, my CNC contractor uses Inventor and Fusion 360. When I export in stp, iges, sat, or even give them my .3dm file, they open the job and get a lot of extra and often non-planar geometry. When I import in Rhino those same very files that I export… everything is fine. I sent it to another contractor who uses Solidworks - they also had huge dramas and had to heal some 130 surfaces.

I have tried every combination of export profile and setting I can think of. I’ve tried other formats like DXF and .obj. And today I downloaded the trial version of Rhino for Windows just to test it on there - same problem.

I could just make my model in Fusion 360. It’s a simple model, wouldn’t take long. But I’m very frustrated that - in 2017 - I can’t export a clean and simple bit of geometry and have them receive something that isn’t a mess.

Attached you’ll see the job as a .3dm and several screenshots of the problem as it appears in F360 (the bulges in the locators were more pronounced before I made the two parts blocks - now most of the issues are bulges in the overall perimeter).

It seems that Rhino is exporting additional information that it can read - as it reopens fine in Rhino - but clearly is outside of spec for each of these common formats and is being read as geometry, as all of these formats create false geometry in the same parts of the job.

What am I missing ?

Problem Export.3dm (784.0 KB)


#2

Can you attach stp / iges / sat files? I will try to import them into Solidworks to confirm if the problem is on the side Inventor/Fusion.

Edited: I tried to export your model from Rhino 5 SR13 to Solidworks 2016 SP4
iges as surfcam and solidworks solids, sat as default - geometry is preserved (the model seems to be flat in all 6 views), none of the surfaces or elements were deformed, however some surfaces were marked as bad(I am skeptic with this automatic tool in Solidworks, sometimes it wants to heal a hole in the surface)
step 203 - geometry is preserved, none of the surfaces or elements were deformed and none surfaces were marked as bad.


#3

Hi Nosorozec - Thanks for the offer, though as mentioned above: “I sent it to another contractor who uses Solidworks - they also had huge dramas and had to heal some 130 surfaces.”

Which already answers that. You can create those files from the .3dm that I have supplied if you want to try it. :slight_smile:


(Jakob Normand) #4

Hi @Tad_Errey

I’ve had quite a lot of success with shrinking all surfaces prior to exporting to STP. I can’t say that it works all the time, every time, but it does seem to help a lot when importing in SWX and F360. I can’t give you an explanation, as I’m no expert on the matter - it just seems as if the excess information of the un-shrunk surfaces somehow confuses the importers. When you shrink your (poly)surfaces, it somehow becomes less difficult to make mistakes… or something like that :slight_smile:
HTH, Jakob


#5

I have seen this before. A lot of your surfaces sweep all around the geometry in one span. If you split the face on the knots it will hopefully fix the problem. I have attached a couple of screenshots to illustrate. Hope that helps.


(Wim Dekeyser) #6

@Tad_Errey, from the pictures above it would seem that you have disabled CreaseSplitting. Run the CreaseSplitting command and make sure it is set to Enabled.

To fix geometry that was created with splitting disabled, run the DivideAlongCreases command with SplitAtTangents=Yes.


#7

Guys, thank you so much. DivideAlongCreases with SpltAtTangents=Yes did the trick.

For what it’s worth - I think it would save a lot of grief if Rhino automatically did this on export to a non-native format; or at least prompted the user that geometry errors may occur.

Thanks again - you make me wish I’d asked sooner… I’ve spent days labouring over this because I don’t like to be the guy that asks a question without having tried everything first !


#8

We have been exporting from Rhino via IGES to WorkNC for 16 years. Tens of thousands of jobs completed using this process. So I’m going to say with confidence that Rhino is the right tool for the job.

However, as mentioned above, there are some steps to take to make sure your files will import cleanly. We also shrink surfaces prior to exporting. Also, as Tom mentioned, don’t have surfaces that wrap around corners. There are a couple of reasons for this, clean imports being one of them, but also, your CAM solution probably has the ability to detect flat surfaces so that you can run a larger bull-nose tool to clean up the flats. If you allow the surface to run around the corners, it’s no longer planar. You may increase your machining time dramatically. Of course, a lot depends on how you’re machining. We do 5-axis machining, so this is a huge time saver.

Dan


(Wim Dekeyser) #9

Did you check the CreaseSplitting command? It should be set to Enabled but for unknown reasons sometimes becomes disabled.


#10

Well, when I punch CreaseSplitting into Rhino for Mac (which is what the model was originally drawn in) it doesn’t tell me its existing state. But I’m guessing that was the issue.