Rhino crashes when opening preferences

Help! I am trying to open my preferences in Rhino 5. Every single time it causes an automatic crash…what can I do? Running Mac OS Big Sur 11.0.1…

Thanks

Hi Phillipp -
Can you run me through the precise steps? You start Rhino 5 - which version?
It starts without problems and then you do what?
Is there a crash dialog and are you sending in the report?
-wim

Hi Wim,

Thank for getting back.

Can you run me through the precise steps?

The steps are as follows;

  • I can open and run rhino without any issues
  • I want to change my mouse preferences, so go to the preferences menu
  • Upon clicking it, the whole program shuts down
  • I get a window (screenshot attached) saying “ Rhino quit unexpectedly”.
  • I click reopen in that window
  • I then get a Rhino Crash Report window (screenshot attached)
  • Then Rhino opens as normal, but the problem persists

You start Rhino 5 – which version?

This is Rhino 5.5.5

It starts without problems and then you do what?

Yes, its starts without problems. The program as a whole, runs perfectly fine. The above steps outline my issue, but I do not know what to do otherwise.

Is there a crash dialog and are you sending in the report?

Yes, there is. I have sent this but not heard anything back.

Thank you for your help,

Phillipp

<img width=“1457” height=“1073” style=“width:15.177in;height:11.177in” id=“Picture_x0020_4” src="//discourse-cloud-file-uploads.s3.dualstack.us-west-2.amazonaws.com/mcneel/uploads/default/original/4X/b/f/f/bff0e7c13d47fa7d57175b4fc8249dee79d38030.png" alt="Graphical user interface, text, application

Description automatically generated"><img width=“613” height=“775” style=“width:6.3854in;height:8.0729in” id=“Picture_x0020_5” src="//discourse-cloud-file-uploads.s3.dualstack.us-west-2.amazonaws.com/mcneel/uploads/default/original/4X/e/4/7/e4724031e91f18d2925984e96b3b86409df21b4c.png" alt="Graphical user interface, text, application

Description automatically generated">

Thanks for that additional information, Phillipp!
It turns out that this is a known issue with running Rhino 5 on macOS Big Sur.
There are a few other known crash issues and none of these will be fixed.
The system requirements for Rhino 5 now mention that Big Sur is not supported at the bottom of this page: https://www.rhino3d.com/5/system_requirements/
-wim

Hi Wim,

Thank for getting back. This is unfortunate to hear as the program runs just fine otherwise. Is this simple bug something that can’t be fixed? or is this the type of thing where Mcneel wants people to have to buy in for the new upgrade/program to get the repair?

Thanks,

Phillipp

Hi Phillipp -

Rhino 5 on Mac runs as intended on the operation systems it was designed for. I’m afraid it’s just not feasible to try to get obsolete software (Rhino 5) to work on newer operating systems. We don’t even have the tools anymore to even be able to try that. You should probably consider to roll back to macOS Catalina.
-wim

Hi, I don’t think McNeel is going to fix this, but there is work around if have another Mac with your old preferences for Rhino on it. You can export a .plist file with your previous preferences saved and import to you new install. If you need to change something new though this is not going to work. I learned how to do through this Rhino link here:

https://wiki.mcneel.com/rhino/mac/resetprefs

Hope that helps, it worked for me to keep using Rhino 5