Rhino 8 C++ Visual Studio 2022 Linker Issue


I just downloaded the SDK for Rhino 8 and ran the SDK installer and VSIX installer.
I’m working in C++ in Visual Studio 2022. I have all the specified SDKs, libraries, and frameworks installed.

However, even when I open a new, empty plugin, I’m getting all these error messages shown in the image. The project compiles, but when I run it I get errors and the following messages.

0x00000008318f9cb8 <Information not available, no symbols loaded for RhinoCore.dll>
0x00000008318f9cb8 <Information not available, no symbols loaded for opennurbs.dll>
Exception thrown at 0x00007FFBF1C72151 (opennurbs.dll) in Rhino.exe: 0xC0000005: Access violation reading location 0x0000000000000010.

I’ve tried adding the RhinoCore.lib and opennurbs.lib to the linker, but does anyone know how to fix this?

Thank you.

I’ve also tried copying the relevant dll files into the output directory, adding paths to the dependencies, etc. But if I’m missing a step please let me know.

Set the build output list to Build only, not Build + Intellisense. That will only give confusing output, hiding actual build errors.

Anyway, from the messages you showed you acn ignore the ones that say no symbols loaded. Instead you have to check 4 frames earlier in your callstack where your code does something with ON_SimpleArray. Probably incorrect indexing into the array, but that’s just guessing without knowing what your code is there.

Thank you for your help!

It seems that the problem was actually something I forgot to change with the string formatting in the print statement.