Rhino 6 with Microsoft SCCM

Is anyone else having trouble with the Rhino 6 installer and SCCM, if I Install with the following command
rhino_en-us_6.5.18155.13161.exe -package -quiet LICENSE_METHOD=ZOO ZOO_SERVER=server.name SEND_STATISTICS=0 ENABLE_AUTOMATIC_UPDATES=0
using SCCM then Rhino will not launch for users on the computer, I do not get any errors it just doesn’t launch. SCCM installs using the SYSTEM account and not the Administrator account. If I run the install as administrator rather than installing using SCCM the software will launch. After installing via SCCM I can run a repair as Administrator and this also fixes the problem. Any help would be appreciated.

@brian, please have a look :slight_smile:

Hi @p.g.turner,

Thanks for your email. I’ve seen several comments like this, and have not yet tracked down the problem. Here’s what I think is happening:

  1. SCCM starts the install
  2. During the install process, a required component is installed (.NET framework, Visual C++ redistributable, etc). That required component calls for a restart
  3. The -quiet flag suppresses the restart, or the executable is not returning a proper exit code for SCCM to see that a restart is required.
  4. Rhino doesn’t get installed because it’s awaiting a restart

There are a bunch of log files in %temp%\Rhino*.log on your computer. Can you please zip them up and private message them to me? You can do that by clicking my avatar, then clicking the Message button.

There’s a very similar conversation here:

Hi @p.g.turner

I’m new to SCCM 2012 and wants to create a Rhino ver 6.0 package. Could you please assist me.


Hi Syed

Create an install batch file with the following lines,

cd /d %0…

rhino_en-us_6.9.18271.20591.exe -package -quiet LICENSE_METHOD=ZOO ZOO_SERVER=servername SEND_STATISTICS=0 ENABLE_AUTOMATIC_UPDATES=0

and then an uninstall batch file with the following lines,

cd /d %0…

rhino_en-us_6.9.18271.20591.exe -uninstall -quiet

If you create a new SCCM Applications and use “Manually specify the application information” option

Give the application a name “Rhino 6”

At deployment type select Add

Select type: Script Installer

Browse to the content Location, the Installation Program and the Uninstall program ( the batch files you created)

Next Specify how the deployment is detected

You can use the file version as a detection, to detect installation

C:\Program Files\Rhino 6\System\



and check the shortcut exists on the start menu.

C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Rhino 6\Rhino 6.lnk

Specify user experience settings for the application,

Install behaviour:Install for system

Logon requirement: whether or not a user is logged on

program visibility: Hidden

and then deploy.

hope this helps.



Hi P.G.turner

Thank you for providing me the SCCM deployment instructions.

We followed your instruction but it restarted the workstation without any prompt. Do you know is there any switch we need to use to suppress the restart?

Thank You.


Here’s a link to the regular deployment instructions including the “-norestart” argument:

Hi Syed

I think you will find it is the prerequisites that are forcing the restart rather than the Rhino Installation, we pre install the Visual C++ Redistributables as these force a restart if installed using the Rhino installer.

I think you need to install the following, this will they stop the Rhino installer trying to install them.

C++2005 (x64)

C++ 2010 (x64) 10.0.40219

C++ 2016 (x64) 12.0.30501

C++ 2017 (x64) 14.12.25810

Hope this helps.


Hi all,

we are facing the same problem with Rhino 6. an unattended installation with SEND_STATISTICS=0 is simply ignored, the installation comes up with the appropriate dialog to accept sending statistics.

Please let us know, in which service package (or Rhino 7?) this bug is solved.


forgot to mention: we are trying to install Rhino 6 Service pack 24 (the current one)