Rhino 6 Drape command


(Jeremy) #1

I tried the Drape command for the first time today. My expectation was that something would drape over objects like a tablecloth drapes over a table. What I got was a mesh that “draped” under the surfaces (like the tablecloth is embedded within the table). I assumed this was a bug until I read the command help which seems to say it is intentional. But if intentional, it seems to defeat the object of a drape, so I’m left wondering whether Drape can ever be useful. Is this a bug or intentional?


(Pascal Golay) #2

Hello - Drape will make a surface with no hard edges, internally - the control points on the surface are on the draped object but the surface itself may cut through hard corners of the input is that what you mean? can you post an example?

-Pascal


(Jeremy) #3

Hi Pascal,

The attached model has a couple of boxes, an ellipsoid and a surface created by offsetting the ellipsoid. Then there is a drape covering part of the scene. Finally there is a layer containing a section through the model which makes obvious how the drape penetrates the ellipsoid and the ellipsoid offset (created using the section tools plugin).

Jeremy

Ellipsoidal extension - second panelling tests.3dm (816.4 KB)


(Pascal Golay) #4

Hi Jeremy - Yeah… the resolution on the surface is not high enough to be accurate - see how it falls away from the target more on the sides of the ellipse? That is where the points are sparse. Keep in mind that this is pixel based so the higher resolution on the screen and the bigger the target objects are compared the the screen, the denser the resulting drape.

-Pascal