How to use Drape?


#1

HI this may seem like a stupid question, but I’m trying to use the drape command and I can’t get the thing to work! I watched the video in the help section a thousand times and I don’t know what I’m doing wrong.

All I do is make a box and then use drape and draw a rectangle on the top view but all it does is make a flat surface!

Anyone know what I’m doing wrong?

drape question.3dm (133.7 KB)


#2

If you where to drop a drape over a sheet of paper it would show flat.
if you magically suspend the {rigid?) paper sheet one ft above ground zero then drape over it…well you get the idea.


(Pascal Golay) #3

Hi Jay- not stupid at all- the tool seems to be at least partly broken- that is, as far as I can see it fails if the sides of the target are completely vertical. If you include at least one object for which this is not true, like a sphere, then it knows what to do, even with the completely vertical objects. I’ll see if we can get this fixed.

-Pascal


#4

That makes sense. Unfortunately, I tried to drape over curvy things and it also didn’t work :frowning:

I tried messing around with the camera and also the autodetectdepth thing but no use.

drape.3dm (435.2 KB)


(Pascal Golay) #5

Hi Jay - this is working here in our latest builds- later than yours… are you running SR8? What are the command line settings when you run the command?

-Pascal


#6

Hi Pascal, I am running “Version 5 SR8 64-bit” educational. I just bought Rhino recently, I hope I got the latest version! :frowning:

The command line when I use the command reads as follows

“Loading Rhino Render, version 1.50, Mar 15 2014, 13:04:20
Command: Drape
Drag a window over area to drape ( AutoSpacing=Yes  Spacing=5  AutoDetectMaxDepth=Yes ):
Creating meshes… Press Esc to cancel”


(Pascal Golay) #7

Hi Jay- can you drape over a mesh object, like MeshSphere?

-Pascal


#8

No I tried that too and it is no different.

drape.3dm (435.7 KB)


(Wim Dekeyser) #9

Just to be sure… Is the plane over the spheres the outcome of the drape command? It looks like it is but just making sure.

Just opening your file, selecting that plane in the top view and deleting it, then typing drape and using the default options, drawing a rectangle in the top view (partly) over both spheres gives the expected result [attached].
drape (wd).3dm (764.8 KB)

I don’t understand what could be going on on your end. FWIW, SR8 is the latest release.


#10

It is acting like AutoDetectMaxDepth is set to No and MaxDepth is set to 0…

@jshethj What happens if you deliberately set AutoDetectMaxDepth=No and set MaxDepth=1? Does it drape?

–Mitch


#11

HI Helvetosaur, when I set the settings to what you describe I get the same result.

I don’t know what I’m doing differently! I have the educational version of Rhino ( I paid for it but it still says education), and I have grasshopper installed, so maybe one of those could be the problem? I’m also using Windows 7.


(Wim Dekeyser) #12

The educational version is identical to the commercial version (it’s only the terms of use that differ). Also running Grasshopper and Win7 here so it must be something else.
Could you post some screen shots or video? (grasping at straws here…).


(Pascal Golay) #13

Hi Jay - what is the video card on your machine? Do you have access to Rhino on a different machine to see if your file works any differently?

-Pascal


#14

Hi Wim, I can post some screen shots.

Pascal I have an AMD Radeon HD 6450. I can go to my school and check if the drape works there, although they have Rhino 4.

EDIT: I tried with the Rhino 4 evaluation on my computer and the drape works!