Rhino 6 bug with 2 rail sweep, works in Rhino 5

When I move a control point in this 2 rail sweep the tube collapses. Not when I open in Rhino 5. Thank you Just rebuilt rails from 8 to 5 and it worked fine. I guess I had too many points. Still I think it should have worked with 8 points. Worked in Rhino five with 8 points
for web 2.3dm (1.6 MB)

I cannot open that in Rhino5

convert to Rhino 5 file to open in 5. I just rebuilt the rails from 8 to 5 and it works normal in Rhino 6 again.

Today I went back to this file and even with 5 points per rail, when adding a slash, the tube collapses when even one control point is slightly adjusted. Am I missing something in Rail from 2 curves options in Rhino 6?

That is pretty strange.
How did you make the sweep? Just pick 2 rails and 2 shapes in the Sweep2 command?

In the file you sent I also see strange history updates, but if I remake the sweep from your curves, history updates correctly.

Yes, simple 2 rail sweep with 2 end sections. The file is part of a ring that I did not send. This has happened to me in other files. I’ve also had to redo mother’s in history inorder for children to react in other files in the past. Never had these issues in Rhino 5

It worked for me as well with 5 control point’s without using “add slash” . It does not work with 8 points. I’m still learning Rhino, and I find usually the least amount of control points is best, but not always (like “Flow along Surface”), and I would like to be able to add slash in 2 rail sweep when needed.

OK, I’d be happy to look at the problems, but the description is too vague and general for me to know what to look at. I’m kind of slow.
I need specific steps to reproduce the problem, or as close to that as you can get, and files with examples of things that don’t work.

Does the file I sent originally, work for you with a slash at quad with 5 control points each rail? Or with “add slash” in your rebuilt rails? When another problem comes up similar to this one, I will get back to you. Thanks for your help

I got something to fail with AddSlash.
I’ll look at it some more now Thanks.

From my profile button, I can see that Dale and John Brock posted on this topic, yet I don’t see them here? Why

No sign, from here, of anything from those guys in this thread.




It’s been awhile and I’m wondering if something that works in Rhino 5 should work in rhino 6 is still being looked at . This only happens with "slash added to 2 rail sweep using all 3 cross sections and I “Scale 1D” the width of the center CrossSection for%20web%206%20after%20scale%201D%20center%20cross%20section%20|690x432

Looks like they edited the tags/category of your original post, so you would have received notifications for that.