Rhino 5 + SpaceMouse Pro + Logitech G600 = lags

Good morning.
I am using Rhino Version 5 SR9 64-bit (5.9.40609.20145, 09-Jun-14) on windows 8.1 with a 3dconnexion SpaceMouse Pro and a Logitech G600 mouse (both with the latest drivers installed) on my laptop. As long as I use the Space Mouse alone (without touching the Logitech mouse), everything works fine, but as soon as I start moving the cursor inside the viewport, the movement of the camera freezes. As I let the Logitech mouse go, the camera “leaps forward” regaining the missed movement. This issue doesn’t happen with other applications (I tried it with 3ds Max and SketchUp) nor if I use the touchpad instead of the Logitech mouse. Is it a known issue or is it just my system?
Thankyou in advance for any help

UPDATE: This morning I asked a colleague to borrow me his mouse (a Microsoft Wireless Mobile Mouse 1000), I plugged it in instead of my logitech then I rebooted the computer and the issue was gone. Everything worked smoothly. So I hot swapped the mice back again and the problem reappeared. At this point I guess it’s something that deals with the Logitech specific drivers, isn’t it? Is there any way to temporarily disable them?

That was my first thought… I’d contact Logitech to see if they can offer another driver. The fact it happens only in Rhino makes me wonder if it has anything to do with the display mode settings and/or OpenGL settings. Check that you have recent drivers for the GPU you’re using. See Options>Rhino Options>View>OpenGL to see what is currently being used by Rhino.

The drivers look all right:

I’ll ask Logitech about it. Thanks a lot anyway. I’ll let you know.

I still use the old UberDrivers on all my Logitech mice (mouses?) Don’t even remember where I got those drivers but it was to unlock the extra buttons when the first mega mouses first came out from LogiTech. Very customizable and I have to be careful to never let Logitech update from my UberSettings. I’ll dig around and see where I got this driver.

Did you ever get this sorted?

I’ve just bought this mouse, and 5 years on, the problem is still there.

Not really, unfortunately. I’ve just stopped using that hardware combo…