Rhino 2D Drawings to AutoCAD for CNC

Hi,
After making 2D drawings in rhino when I convert it into AUTOCAD .dwg format file for CNC cutting, I find the line positioning and shape changes. Moreover, I find Rhino not suitable for CNC operation. Our CNC machine can’t take rhino files as input. so, I can’t but convert the file into dwg. After this conversion, the problem is occurring. I would not like to draw in AutoCAD as I find Rhino is robust and has a lots of features. But for CNC cutting it is really troubling a lot.

I am getting the gaps, see attached photo. though it was not in rhino file.

What I do before exporting is that I use explode and convert command. The lines stay still fine in rhino but not in Autocad after conversion.

I am using the following settings.

Could you please help! What is the best settings for exporting Rhino 2D drawings into AutoCAD for CNC operation?

Hi, Can you post an example rhino file that shows that problem when its exported to dwg?
One with just a few lines in it would be the best.

So it looks like your are after just a 2d version of the shape? Rhino has a command called “make2d” this reduces the model to curves in a plane. I use curve boolean to also get the out line of shapes that I am after. Also try moving the shape that you want into the orientation that works for your CNC, then use curve boolean or mesh outline to get the profile.

Bill

s.dwg (45.4 KB) sample.3dm (100.4 KB)

However, I have found a solution and my mistake. I forgot to explode and convert the white lines before making the Autocad file. Anyway, if there is any other faster and effective way please let me know.

I also use Curveboolean. Make 2D helps me to orient in 2D plane. But for CNC I need to make it polylines. Make 2D doesn’t convert curve into polyline. So, when I take the curves directly from Rhino to AutoCad, the curve changes into spline. I find the conversion of spline into polyline in Autocad is difficult and problematic. That’s why I explode and convert the curves into arcs and lines in Rhino first, then take them in AutoCAD. It solved my problem.

If you use one of the available CAM export schemes when you write the dwg file from Rhino, splines will be converted to polylines.
There are some settings in the EditSchemes->Curves dialog to control exactly how that is done. I tested your file with the standard CAM Metric scheme and it looked good to me.

1 Like

Thanks a lot. :slight_smile: