Resample texture - no texture slot

Hi, I was trying to play around with the displacement features in rhino, and was attempting to use the “resample texture” which the first time I tried it worked - I didn’t save that as it was just a quick try, and needed to work on something else.

Now when I have come back to it and tried again, whenever I create a “resample texture” there is no slot to add a texture to resample. I don’t know if I broke it somehow or if I am doing something wrong? I have tried creating different materials, adding different textures, starting from scratch - nothing seems to work.

Thanks for any help if anyone knows a fix.

Also now it appears trying to use a texture as a displacement map as part of a physically based material is broken too.

Using it directly as a displacement map seems to work.
Using it as a displacement map as part of a material just moves the whole render mesh as a flat surface the amount of the displacement value.

I feel I have somehow accidentally managed to change a setting that affects this but don’t know what or how to fix it.

Anyone have any help with this?
Displacement mapping doesn’t work now.