RenderMaterial (rmtl) save bug

Hi @Gijs,

there are some bugs when saving multiple render materials from the Material browser. To repeat what i see, please try below steps:

  1. Open a new file without any render materials
  2. In Material browser, click the menu and choose “Import from Material Library…
  3. Navigate to any folder and import multiple rmtl files at once
  4. After the materials where imported, change the thumnail size a bit bigger
  5. Wait until it updates the material previews in the material browser
  6. While all materials are selected, choose “Save to file…” from the menu
  7. Create a new empty folder and click OK to start saving

This will bring up below dialog, for each material you want to save:

grafik

If you enable the checkbox to “do not show me this dialog box”, the No button gets disabled. It seems you must embed bitmaps because you can only pick Yes then. Makes no sense to me if i want to save all material files without support files…

Just click No for every material to get past this. If you now go to your folder in explorer and enable the file display mode to Large Symbols, you’ll see that only the first material has a preview image. All others are black.

this happens in Rhino 7 and 8 (Windows). The xml does have the base64 string for the <thumbnail> nodes though, it just may be corrupted. I do get the same results if i choose Yes in the dialog box btw.

_
c.