Record History not working properly

I am having problems with my rhino 6. Record history is set to on and it updates other commands but it does not work for objects mirrored using Mirror X and Mirror Y.

Hmm, seems to be working here with a simple test. Can you post a file with an object where Mirror X or Y are not working with history?

Simple mirror command is working correctly as usual. I mean choosing center as start of mirror plane and the objects created by that command update whenever parent object is updated. It is quite strange that Mirror X and Mirror Y are both broken here on my machine. I uploaded the file here.
The object on the left is parent.

Hello - these objects indeed have no history - remains to see how, exactly, you did the mirror -
Click Record History to make it bold
Select a box
Start Mirror,
Click YAxis
MirrorHistory.3dm (211.8 KB)


As I said, seems to be working here…

I have uninstalled my Rhino 6 and reinstalled from scratch but the problem still exits. I know I could use just mirror command but I use keyboard shortcuts for Mirror X, Mirror Y and Mirror quadruple so it’s kinda frustrating that only my machine has that problem. I hope the above video might give you some information.

Hi - that toolbar seems to be from a 3rd party plug-in. What are the command macros that are under those buttons?

Yep, appears to be RhinoGold…

Just change those keyboard shortcuts to

! _Mirror _Pause _X
! _Mirror _Pause _Y

for the first two.

Here is a script for QuadMirror that includes history recording. (999 Bytes)

And one that allows you to chose the origin point instead of being fixed at the active CPlane 0 (1.1 KB)

Store the .py script somewhere on your computer, then make your keyboard shortcut as follows:

! _-RunPythonScript "full path to file"

where full path to file is the full path to the .py script including the filename and extension.

1 Like

Hi, I am getting problems with record history. It`s not working.
see this video


Hmm, I tried to reproduce here what you did in the video, and History seems to be working correctly…

Hi Affonso -
Please run the Rhino SystemInfo command and copy-paste the result here.

Rhino 7 SR15 2022-2-8 (Rhino 7, 7.15.22039.13001, Git hash:master @ 2833e18992fc4b5cf99bb29c4d8e8add4f02074d)
License type: Lab NFR, build 2022-02-08
License details: Cloud Zoo

Windows 10.0.19044 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) HD Graphics 630 (Intel) Memory: 1GB, Driver date: 9-5-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1
Primary OpenGL: NVIDIA GeForce GTX 1050 Ti (NVidia) Memory: 4GB, Driver date: 4-23-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 466.27
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-23-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Geometry Gym\Rhino7\ggRhinoIFC.rhp “ggRhinoIFC”
C:\Program Files\Bongo 2.0 (64-bit)\Rhino6\Bongo.20.rhp “Bongo 2.0”
C:\Program Files\Pachyderm_Acoustic\Pachyderm_Acoustic.rhp “Pachyderm_Acoustic”
C:\Program Files\Rhino 7\Plug-ins\RhinoCAM 2021 for R7\RhinoCAM 2021 For Rhino7.0.rhp “RhinoCAM 2021 - The cutting edge CAM plug-in for Rhino 7.0 from MecSoft Corporation”
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Program Files\Rhino 7\Plug-ins\RhinoCAM 2021 for R7\RhinoArt1FileExporter For Rhino7.0.rhp “RhinoArt1FileExporter”
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Twinmotion Direct Link 2020.2 (e24ee14a-9514-47da-8fe6-f6e61b20160e)\Twinmotion Direct Link 2020.rhp “Twinmotion Direct Link 2020”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”
C:\Users\Affonso\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\KeyShot9RhinoPlugin (ecfe8d1f-876a-460f-aa5e-3dd816936811)\\KeyShot9RhinoPlugin\Rhino 5.0\KeyShot9RhinoPlugin.rhp “KeyShot9RhinoPlugin”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.15.22039.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.15.22039.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.15.22039.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.15.22039.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.15.22039.13001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.15.22039.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.15.22039.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\Affonso\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2020.9.1.565\PanelingTools.rhp “PanelingTools”
C:\Users\Affonso\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.30.511\SectionTools.rhp “SectionTools”

Hi Alfonso - please disable the plug-ins that do not ship with Rhino in Options > Plug-ins page, then close and re-open Rhino.,… I expect it will work now - if so, enable these plug-ins one by one until the bad behavior returns - then we’ll know where to point the finger.


Hi Pascal, tks a lot I am doing it. Then I will answer you. By the way, yes, I work with a lot of plug-ins. Also I got problems since 2 years ago with RhinoCAM, just crash when I simulate the tool path. Hope that today I will check everything. tks a lot for your help. best. Affonso Orciuoli

Dear Pascal. I disabled all my rhino plug-ins, and still not working the record history. I am totally lost. If you want, we can organize a google meeting or teamviewer, etc… tks a lot.

Hi Alfonso -

Please run the Rhino History command and just hit Enter to exit the command again. Then copy the command line history and paste that here.

dear Wim!!! bingo… the update was = no…
now is working, tks a lot!!
all the best

1 Like