Rebuild Curve causes Rhino 6 to crash in new SR

I downloaded the new SR today and tried running some GH definitions. Rhino kept crashing and so I whittled it down to the Rebuild Curve component, not that it is exclusively that. Trying the Rebuild command in Rhino itself also causes a crash.

Hi Ethan - does this crash using the Rhino command happen with any curve? Any settings? If not, please post an example.


Hi Pascal,
Apparently it does work for open curves. I tried it on several closed curves and it consistently crashes. For a closed curve, I don’t even have the opportunity to enter settings before it crashes.
Closed Crash Curve.3dm (27.1 KB)


Hi Ethan - yep, I found that here too - thanks
@akilli - can you please run SystemInfo in Rhino and paste the results here?

thanks for the report!


system info.txt (1.8 KB)

Got it, thanks… to go back to 12, (official SR, you must be set up to get ‘Release Candidates’ in Options > Updates and Statisics) Uninstall from Windows control panel and install from the current SR here:


Ok Pascal, everything seems back to normal. Thanks.

rebiuld comman in rhino sr13 have bug and crash rhino and freezes in close curves in my pc too

same problem here open curve rebuild goes ok a closed curve crasher rhino without warning , latest version

The same here.

Thanks, all, for reporting. As Pascal wrote, the issue was reproduced on our systems and the YT issue is in the tracker.

A post was split to a new topic: When working in Grasshopper, sometimes Rhino freezes

Issue also on SR13 on my PC. Went back to SR12, no problem.

RH-50639 is fixed in the latest Service Release Candidate