Quick way to find out if surface planar or not (degree level doesn't work)

I transformed the object and hence most surfaces are bent. But I have to reconstruct everything with planar surfaces to get the final sofa sculpture production ready.

Is there a quick way to find out, any indicator or shortcut (rebuild surfaces would show degree 1 surfaces which is not true if a surface is bent as far as I know)

Thanks a lot!

Hello - try `SelPlanarSrf’

-Pascal

2 Likes

@pascal Thanks for the tip! works for me :slight_smile:

Hannes

you can also look at the gumball…if there is no scale handle in one direction you are usually planar.

you may have to orient the gumball to object if the object is not oriented world xyz

Smart :brain:
I love it! Thank you Kyle!

Hannes

@theoutside

A rectangular plane that stays flat as it’s edited it something I’ve wished we had from time to time.

@theoutside Kyle as you look here this one has no z handle and is not coplanar - hence the trick is not that reliable.

image

@JimCarruthers yes would be nice to lock it in some way…but I’m getting better with workarounds.

@pascal do you know a script like FlattenMesh where you invert select all co-planar surfaces and then with all non-co-planar surfaces selected to force all of them to calculate their points through one average plane and use that to cut the created co-planar plane which would result in each new target surface to be co-planar and nearly the shape as the original surface?

This way, I could easily work further on my final sofa sculpture and not mess the overall co-planarity up.

thank you!

Hannes

@theoutside @pascal ok I missed to check gumball alignment to ‘object’ but doesn’t have a handle either.

tried to convert NURBS into meshes then “flatten mesh” and then convert back. An automatic way to make all surfaces coplanar would be great.

@pascal Is there a way to lock surfaces to remain co-planar when editing them?

Hannes

This is my workaround with the Gumball, even the Gumball is not auto-updating and the z-handle is not always visible in C-Plane alignment, object alignment the z-handle is not existent maybe @pascal this is a bug - otherwise with object alignment on this would be a perfect workflow. thank you

set your cplane to the surface(s) and use project in osnap

1 Like

and this can be done by setting CPlane to object and then use:

-_SetPt _z=_yes _x=_no _y=_no _Alignment=_Cplane 0

2 Likes

@Gijs !!! this is it. did a test, you have the same results without checking "project’ in OSnaps