Projected surface match fails despite "refine" checked

I’m curious as to why this fails, since the surfaces are really simple:

join.3dm (976.4 KB)

Now, I’ve already fixed it by upping the complexity of the green surface, but again I’m annoyed that the match tool fails without warning…

Hello - I agree the Refine seems not to be adding the expected knots in this case - my guess of the moment is that it is right on the edge - so to speak - reducing the tolerance forces the knots to be inserted. Though, I generally tend to insert a knot or two manually, as Refine, when it does kick in, often is a little to enthusiuastic. At any rate, I will put this on the heap, thanks for the example.


Thanks… I almost deleted the topic because I figured that the trim line of the blue surface wasn’t matched to the green anymore, but I just double checked that by re-trimming the blue surface with the green and it didn’t make a difference.

Yeah… this is even after I upped the complexity of the surface…


(At least it joined after this.)

The problem of a failing match can be solved by showing the deviation of the match from within the command. This way the user can decide how to refine the surface to meet the required quality.

The rebuild command for example also shows a deviation.

The current workflow is just guessing and hoping for the best… However this was talked about here and here, but was not considered.

Yep, and Patch could use the same



There is a mismatch between the bottom edge of the blue and the green surfaces. You can check this by Pulling the edge of the green to the red then comparing that curve with the edge of the blue.

What determined the shape of the right edge of the blue?

An alternative to match the green to the blue is to ExtendCrvOnSrf the blue edge on the red surface, then use that curve as the input for “Select curve or edge to match”.

And BlendSrf, Loft, NetworkSrf, Sweep1, and Sweep2.