Problems with wobbling surface


#1

Hi,


I have created this surface. As you can see, the surface has “wobbles”.

what I made wrong?
It’ made by
Rhino->Surface->Sweep2Rails
first select the rails

and then selecting the profiles

they have the correct orientation. And every Profile has the same amount of control points. The profiles are all the same, but modified by “scale”.

by changing the parameters, the bottom line gets a wave?
Here an analysis:

the round spots between the profiles are the problem.
I want to create a clean surface.
Thanks for Help
Carsten


(John Brock) #2

Way too many sections.

The command isn’t the problem. It’s the input curves.

You need the ones at the ends and one anywhere you need it to be a specific shape like the bulge in the middle and where it necks down before the big flare.

Also each section should be the same degree, have the same number of control points, and be generally arranged the same.

Basic rule of NURBS surface modeling is less is better. The fewer control points you use and the fewer sections you use (that still accurately represent the shape), the “cleaner” and smoother the surface will be.

The visual give away is the large number of isocurves in the surface.


(Bob McNeel) #3

@cajodo, You might try using RebuildCrvNonUniform to rebuild the curves as a group.


#4

@John_Brock:
The curves are airfoils. They had to be accurate. And all “Profiles” are a copy of one “Source Profile” which is scaled. moved and oriented.

@bobmcneel:
Rebuilding the curves will change the airfoil-profile. That is not a good solution for CNC-Milling. Or am I wrong?

Using “RebuildCrvNonUniform” will get something like this: (please zoom in for Details)


#5

As John said, there are probably too many profiles. If you need to follow the rail curves exactly, you may need to use Sweep2 instead of Loft. The more profiles you have, the more you will get “undulations” along the length of the surface as it tries to pull the surface through each profile.

The other problem is the original “Source Profile” from which the other profiles were derived has far too many points. I estimate that it could be done smoothly, fair and accurate to within tolerance with perhaps 12-15 control points… The current curves will make for very “noisy” surfaces.

As everyone in here will tell you, the trick to getting good surfaces in Rhino is making good, clean curves. If you don’t start with those, there’s not much hope.

I don’t see any indication of the size/scale of the airfoil, but if you are going to be machining these surfaces, you need to determine the tolerance which you need to hold in machining. Then you can reconstruct your original curve with fewer points but matching the original to something like 1/10 of that tolerance. Your tools for that will be point editing with curvature graph on to make sure your edits are keeping the curve reasonably smooth. Keep a copy of the original and use CurveDeviation to compare your edited curve to the original to see where the max deviation is.

Once the source profile is good, re-do the orientation to create the other profiles from the new one. You should then get a clean, accurate loft. I do not think there is an automatic way to rebuild all your existing profiles and be assured that all are within tolerance, that’s why I suggest going back to the beginning and starting over (unfortunately).

–Mitch


#6

Hi Mitch,
I made my homework, as you can see. I have made all Profiles NEW. …

but the result is nearly the same:


as you can see the “eyes” on the "ZebraSurface"
The wobbling is less than in the beginning of this thread. But not away. I don’t understand where the problem is from. For me: Rhino “only” had to blend between the curves. Where is the wobble from? If the curves have different amount of control points OK, but they have the “same” control points.

P.S.:I have created the surface with “surface sweep 2 rails”.

Carsten


#7

Hi Carsten,

check your curves (rails and sections) with curvature graph. Do they have a perfect curvature ? What are your mesh settings in the zebra command set to ? Make shure it is not coarse as only the mesh curvature is displayed.

If you could post your curves we can have a closer look how to improve the surface quality. With pictures this is not easy.

c.