Problem with install

I tried Panther3d yesterday but I was so disappointed on Windows 10 latest service release. Even the Anti-Virus had to be disabled. As it was reported as a Virus program. Once uninstalling the Anti-Virus, it installed but all the menus were compressed. i.e, I could not read any of the letters. I managed to type my login and password, but it would not log on. I tried this many times, then uninstalled and reinstalled the program after which I was left with a broken uninstall. I managed to fix this after spending two hours and some online time with Mcneel.

I would love to buy this program but I see the last update was in Feb. Is this a waste of money or is it worth investing in this product???
Kind Regards
Michél Nunes

I have managed to fix the font problem. I have to work at a very low resolution but it works. Cannot login to activate the licence. Disabled the AntiVirus but no go. Can anybody please advise?
Many thanx.

Hi Michél, thanks for your message. We have just replied to your email in order to assist.

WOW! That is awesome service. I managed to log in no problem. Could you advise which resolution to use on a 13" Macbook Pro i7? So as not to have problems?

Many thanks for all! Very impressive!!!

Thanks Michél, we recommend full HD (1080p) and Windows font size to 100%
Please confirm.