Projects disassociate from Panther after closing file

I have a problem. Once I create a ring, save and then open the file again, I cannot edit the ring in Panther anymore. One of two things happen. Either the tools are missing on the right hand side, or the are there but do not action at all.
Is there anyway to re-enable these projects again with the Panther elements? I have put alot of work in my projects and now they seem useless…and thye are uneditable in Panther.


Have you tried contacting the Panther developer directly about this issue?

Yes I have. They responded until I bought the product and now no more!!!..I had major issues at first but they have brought out two updates since, Improving but not solving this issue. Pity they do not work with their customers as it is a program with a lot of potential. It is frustrating working on a drawing which takes you a morning to do and then it stuffs up!!! Makes me mad…!!!

It looks like they have a pretty good support setup on their own site.
Have you use those resources?

Yes I have. The agent here also has they same problem I have on his Macbook Pro running Windows 10 in bootcamp. I mail and cc panther support. I liked working with panther directly. Sad that I am not hearing back now. Sometimes a “ we are aware of your problem” e-mail is a good thing…I also have program freezes. I send all the reports to you and windows.

Since Macs have AMD graphics cards, and the AMD Windows drivers are pretty hit an miss, if it were me I’d see if there are updated drivers for it:

I’m not saying this will fix everything, but it might help with the freezing:

Any better?

The Macbook Pro 13” i7 has Intel Iris Plus 655 Graphics.(Latest drivers) If they can guarantee me that the program will work, not crash, and not loose its tools on a Windows gaming laptop with a Nvidia card I’ll go and buy one now. However, like I said, no word from their side…

Well, the Intel iris chips are under powered and unrecommended under all circumstances.
If I was going to run Windows Rhino, it damn sure would not be on a Bootcamp partition on a Mac. Back when Macs used Nvidia GeForce cards they were pretty good. Not since they moved to AMD

I’m running a Windows Desktop, i7, 16GB RAM, Nvidia Quadro P2000, two 27" monitors, and a 512GB SSD.

Cool, now that is the kind of answer that I was looking for. Now if we can just be sure the program will not loose its elements I will be off to best buy in the week. Its a massive outlay if I am not sure it will work and it is program related rather than hardware. The Macbook pro is rather new.

The MBP will be fine for occasional use when performance is not important.
I would be running Rhino V6 for Mac on it.
I have a 13" MBP with an Intel chip that is fine for the odd project at home.
I also have a 16" MBP with a good AMD chip. It’s fine for Mac Rhino. I will not ever try to run Windows on it.

If I have work to get done, I use the Dell 3620 tower I described above.
I also have a 13" Microsoft Surface Pro 5 (Intel graphics) this is slow but thin and light for when I need a portable Windows system. It’s not a workstation. I’ve traded off a lot of performance for portability and Jeez-oh-Pete were the portables expensive…

We have no control over plug-ins. Most are quite good. I just don’t know anything about Panther.

You have an Awesome hardware setup! Your program is rock solid in bootcamp and windows boots up faster than on a windows machine! Without the plug-in it never skips a beat! I have installed but not tried the Mac version yet.There are not many online classes for Mac Rhino for jewellery, so I am first getting it right in Windows and then I’ll do the mac version. I see mac is moving to ARM so I wonder what the way forward would be…! Also have a brand new iPad Pro! Awesome machine, and it can view the Rhino projects for the customers. I will look into the windows machine as my main Rhino. Will wait on Panther for answers. On the website they said they support Panther on Mac with bootcamp. That is why I bought their program, and of course the good support at the time. I will report back as to how it goes and if I buy the Windows machine. Many thanks for your feeback. Much appreciated!!!

I am running Panther 1.0.2007.8 on a 15" Macbook Pro, Retina Display, i7 processor with discrete video card NVIDIA GeForce GT 650M under Bootcamp (Windows 10, 16MB RAM). So far it hasn’t frozen, however after saving the file and opening it again sometimes the Panther components are not showing in the Panther panel. After adding any new Panther component (e.g. a gem), the Panther panel gets populated again with the previously created components.