Printing shaded views - surface edges color incorrect


#1

I use the shaded view for my design work, and for better contrast I have set the surface edges to black instead of a shade of the surface display color. However, when printing a shaded view the edges appear in (a shade of) the surface color.
I use these prints for instructional purposes and I really would like these to be black.

I checked the latest WIP (5C133w), and the error is still there.

Max.


Pen Display View Mode and Object Display Mode
#2

Anyone else noticing this and bothered? It seems that single color edges are missed in the printing protocol for Shaded Views.

Max.


(Dan Belcher) #3

Hi Max-

I think I see the behavior you are describing. Do you get the results that you want if you use these print settings with your Shaded display mode?

(I suspect not, but I wanted to check).


#4

Nope, same result.


(Dan Belcher) #5

Really? Strange. Then I think I need more detailed instructions for how to reproduce the issue you are seeing (or expecting to see).

Here is what I did (RhinoWIP 5C133w)

  1. I created a Box.
  2. In Preferences > Display Modes, I created a custom display mode (based on the default Shaded mode) called “Shaded copy”.
  3. In “Shaded copy” settings, in the Objects tab, under the Surfaces section, I set Edge color usage: to Use single color for all edges and set the Edge color to Black.
  4. I set my Perspective viewport to Shaded copy.
  5. Print.

…now, when I used the default settings from the Print dialog, I thought I was seeing what you were reporting: the edges looked more grey than black to me. So that is, perhaps, a bug. But I wanted to see if I could work around that…

So I changed the Linetypes and Line widths settings to match those showed in the screencapture above, I get nice black edges on my surfaces when I print (to PDF). You’re not seeing this?

Where am I going wrong?


#6

Nowhere, that is exactly what I did (I think). Pictures > 1000 words:


Screen print:

Print result (pdf from printing UI):
Edge-test.pdf (211.0 KB)

Max.


#7

There is one thing we both did not mention: Visibility settings
I was using “only selected objects”, but at a hunch I unticked that box and voila: it works as expected.
So the problem occurs only when you want to just print selected objects.

Max.


#8

Just to be clear: although I have narrowed the problem down to printing selected objects in Shaded view, it still needs resolving.

Max.


(Dan Belcher) #9

Understood. Thanks Max. This is still on our radar…


(Dan Belcher) #10

Hi Max.

I tested this again in 5C146w (the latest RhinoWIP) and I am still having problems reproducing the behavior you are seeing. I’m drafting up a TODO item: MR-2651 …sorry to be dense about this, but what am I doing wrong? Can you please take a look at the steps I’ve drafted in MR-2651 and see what I’m missing?

Thanks,
-Dan


#11

Hi Dan,
I stumbled upon this once again using the latest WIP, so I searched for this thread to see how this bug was recorded and I noticed I never replied to your latest request. Sorry about that.
The step that you missed between #10 and #11 is to go to the “visibility” options in the printing dialog, and check the box “only selected objects”.

Max.


(Pascal Golay) #12

@maxz, @dan - here, with ‘Selected objects only’ in Visibility, I get a blank white page in the pdf preview, without that setting I get object color edges, even though the viewport shows black edges - the original complaint, I think.

-Pascal


#13

Not the original complaint Pascal, see my post about halfway. The complaint was and is colored edges with “Only selected objects”, black edges without ( i.e. printing all visible objects).
I am puzzled why you are getting a blank page though, assuming that you did select some objects to begin with.

Max.


(Dan Belcher) #14

Thanks for getting back to this and for the clarifications. I’ve amended MR-2651 with the steps as I understand them. Please double-check those as I’ve changed them to integrate your feedback.

Unfortunately, I’m still getting the same expected result from where I sit. Can you please walk-through the steps in that item to see where I’m going wrong? I feel like I’m missing something obvious here :confused:

Thanks,
-Dan


#15

Hi Dan.
Th steps in MR-2651 are now correctly describing my actions. However, I am getting a different result, I’ll let the pictures speak for themselves:

However, I noticed something that may hold a clue: as soon as select an object and open the print dialog, the black edges change to colored ones, even before I check the “only selected objects” -box!

I tried changing the select color, without result.

Some of my settings:


Hope this helps,
Max.

Edit: Note that all my examples above are using “Display color” as the output color. “Print color” does not show the black edges at all, regardless of the visibility setting. “Black and White” shows black edges all the time.

It looks like the examples you showed in your MR-2651 write up are using black as the object color ( I cannot see your output color setting), which will always have black edges since that is the native edge color, so you would not be able to see the difference.


(Dan Belcher) #16

This bit of clue I’m not sure what to do with, but…good news…

I am able to reproduce what I think you are seeing (finally!) I was doing something quite wrong, which you noticed:

Yes indeed, in the MR-2651’s writeup step 4, I wrote Black! (I’ve since changed it to Blue). That was a mistake on my part…now that I change that critical detail, I think I am better understanding the report. Can you please look over MR-2651 once again to make sure? (I’ve edited it quite a bit).

Thanks again!
-Dan


#17

Hi Dan,
I am glad that this bug continues to have your attention, but I don’t quite understand why you have gone a different route and color the edges blue instead of the object cyan as I did, but in the end it does not make a difference I guess.
My comments on MR-2651:
step 8: There is no reference to the visibility settings when the picture was taken. Assuming that “only selected objects” is not checked at that point, it already displays my “clue”, in the preview the edges appear black instead of blue.
This makes step 9 sort of obsolete. It may be better to move step 6 (selection of the object) to a new position between #8 and #9, and edit step 9 to show that toggling the “only selected objects” setting makes no difference.

As you can see, I am getting more and more convinced that selection of objects is triggering this phenomenon, and not the visibility settings.
I made this screenshot of two objects, the larger cube is selected, the smaller is not. “only selected objects” is off.

Max.


(Dan Belcher) #18

Sorry, I’m probably overly fixated on the title of this topic, or the “surface edges color incorrect.”

How about this, since I’m completely confused, can you please write out the steps you are taking again to reproduce what you are seeing? I’m unable to get the preview to show the wrong color. I just want to make sure we’re taking the same steps and seeing the same thing. Feel free to just copy/paste from MR-2651 if you like. I’m not even sure what I should be looking for anymore.


#19

OK, here goes:

To Reproduce:

  1. Launch Rhino for Mac; start a new modeling window.
  2. Set layer color “Default” to cyan.
  3. Create 2 Boxes.
  4. In Preferences > Display Modes, create a custom display mode (based on the default Shaded mode) called “Shaded copy”.
  5. In “Shaded copy” settings, in the Objects tab, under the Surfaces section, set Edge color usage: to Use single color for all edges and set the Edge color to Black. Close the Preferences window.
  6. Set the Perspective viewport to Shaded copy…at this point you should have a cyan box with black edges like this:
  7. Select one of the boxes you created in step 3 above.
  8. Run the Print command.
  9. In the Print dialog, change the Linetypes and Line widths settings to match those showed in this image:
  10. In the Print dialog, check Visibility to ensure all objects are printed:
  11. Print to PDF using the PDF > Save as PDF option in the lower-left corner of the Print dialog.
    EdgeColorTest.pdf (217.1 KB)

Expected Result: The surface edges print in black.
Actual Result: The surface edges of the selected object print in cyan.

Max (sorry, I did not manage to capture volatile dropdowns from my screen as you did to show the view settings)

Edited: I removed the “lighter shade of cyan” bit, in fact the edges are not distinguishable except for the darker shaded surfaces


(Dan Belcher) #20

Thank you @maxz! Finally, I’m seeing what you’re seeing. Much appreciated. I will amend MR-2651 with your instructions. Thank you for the hand-holding here.

-Dan