Prevent scroll locking when zoom is disabled

I have a Shapediver model rendering on a page that has content below it and I’d like to allow the user to scroll past the model normally to view the content.

It seems that even if I disable the zoom controls, the scroll locks when the mouse (on desktop) or the cursor (on mobile) is attempting to scroll over the area where the model is rendered. Is there a way that I can disable the scroll-locking in order to improve accessibility?

Thanks!

Hello @Tim_Thimmaiah,
this is a great request. I created a ticket for it, that if you disable zooming, the events are not processed by the viewer. I’ll let you know once this is done and how it is implemented!
Cheers, Michael

1 Like

Great thanks! Should I just stay tuned to this thread for an update?

I will just link you here in this thread!
I created a Jira task on our end and linked this thread, so no worries, should be done within the next weeks.

Hello @Tim_Thimmaiah,

in version 1.14.1 you can access a deeper level to disable these eventlisteners.
The call for this is viewer.domEventEngine.allowEventListeners({mousewheel: false})

Let me know if that works for you.

Cheers, Michael

1 Like