Possible bug with keyboard bindings

We are noticing that if we try to create a keyboard binding where one of the commands is from a plug-in (compiled scripts), the native Rhino commands take precedence, regardless of the order that they are in.

For example, I have a command called Dist3D that lists a distance in both imperial and metric after picking two points. If I try to bind that to a keyboard combination like Ctrl+E (or whatever) with a native command, like Line, Line will run first.

! _Dist3D _Line

The Line command will run first, then the plug-in command as seen here:


Am I missing something in the syntax of that command string, or is this a possible bug?



Hi Dan, I think you’ll have to _Pause for input.
Hope it works with your script.

I tried that, but it doesn’t seem to keep the native Rhino commands from taking precedence.

It’s also an issue with the Macro Editor

Oh yes - now I remember. I’ve just tried it with a compiled Python script and it behaves the same. So it seems to be a script-runner problem. One might call it a feature but I’d also call it a bug.

If I’d like to run a command inside of compiled scripts then I should use the apostrophe.

Uhm Question. ^^ Is your CTRL-E Working without the _Line?

Why use the pause in the script and not in the pre-compiled version?

Yes, compiled commands work fine without a native command included. The pauses aren’t necessary, they are in the command. It was just an experiment to see if it made a difference, which it didn’t.

Hi Dan- I can reproduce this here. I’ll put it on the pile, I don’t know what is expected here, but someone with a bigger brain will have a look- thanks.