Peters tools plugin error


I’ve installed peter’s tools for R6 and it works fine, but I’m getting the following error message every time I close a file:
can anyone help?


Maybe it’s because the toolbar file is in a directory where file writing is not normally allowed by current versions of Windows - sub directories of Program Files are not writable without admin permissions, and even then you have to answer a UAC prompt.

Maybe you could do the following (not sure if it will work, but it should):

  • Close the Peter’s Tools toolbar from within Rhino (Options>Toolbars)

  • Go to the directory where the toolbar file (.rui) is currently located and copy it

  • Place a copy of the .rui in the normal toolbar file location for Rhino:
    (this is a hidden directory, you wll need to show hidden items to find it)

  • Again in Options>Toolbars, hit File>Open and browse to the new location of the .rui file and hit open.

  • Hit OK to accept the toolbar, then try closing Rhino and re-opening and see if the message disappears and the toolbar is still there…



thanks so much. That’s done it.

Amazed that you can carry all that info around in your head!



Only issue now is that rhino script is no longer working…

Command: _-loadscript
Blocking plug-in RhinoScript.
Unknown command: _-loadscript

something is now blocking rhinoscript…

Any ideas?

Long shot - but at least something to try:

thanks Wim,

It wasn’t enabled and loaded, but when i try to load it I get the following:




Have you also tried the step that Dan added in that thread - i.e. run a Repair on your installation?

Thanks Wim,

How would I go about running a repair on my installation?


Go to Windows Control Panel>Programs>Uninstall or change a program and find Rhino 6 in the list.

Right click and choose “Change”, a splash screen will come up, hit the “Repair” button…

Sadly that didn’t help:

Here is the command line:

Command: _-loadscript
Blocking plug-in RhinoScript.
Unknown command: _-loadscript

Are you using an anti-virus program other than Windows Defender? These can sometimes block the RhinoScript plug-in.

I’m using Bitdefender. I’ll try to add rhino to the safe programs.

in the meantime i’m trying a clean install of Rhino 6.

Many thanks,



So I’ve done a clean install of R6, and even before I try to modify the program in any way (add plugins/scripts etc) when i try to load rhinoscript I get this error:


I can’t tell from this if you have tried to disable BitDefender.

Hi Wim,

I have now disabled the antivirus completely and it works!

Not sure how I will run Bitdefender and rhinoscript though…

Many thanks,


I guess maybe this can help…

thanks, I’ll give that a shot.

Weird that this all started with moving a toolbar file as it all worked fine previously…


Maybe your BitDefender decided that the move was a rogue operation and decided to quarantine the Rhinoscript plug-in as the scripts in the toolbar file reference it… go figure.

The RhinoScript plug-in enables a technology called COM which allows for starting and automating Rhino from an external script. From what I understand that specific technology is something that virus protection apps look for and can misdiagnose.