OpenNest Issues

I am running into a bit of trouble with OpenNest

unnamed

When I feed the fin geometry and the text labels it gives me this error

  1. System.NullReferenceException: Object reference not set to an instance of an object.
    at OpenNest.OpenNestFullComponentCleanUp.SolveInstance(IGH_DataAccess DA)

I have looked everywhere but I can not find what is going on,
What do you think

Thank you

It’s hard to tell for the screenshot but nesting with OpenNest is well explained in this video tutorial. It’s worth watching the whole tutorial series, there are techniques and recommendations on how to optimise your Grasshopper definitions.

1 Like

Hi @camilo1, can you please send the model to see if we get the same error?

200601_Parametric Wall Frames_GH.gh (36.4 KB)

Absolutely here it is.

Did you test example files?

Ideally input curves must be closed polylines and other attributes like text, 3d geo, engraving curves, must be transformed using T output. This is also described in examples.

@camilo1, you didn’t internalise the input curves in your definition so I replaced them with a rectangle component and the nesting works. I wonder if the curves for Sheets are the troublemaker here.

I internalized them, but it still does not work, i’m starting to believe the issue might be on the way i installed OpenNest

I did that but It somehow still does not work on my end


I am starting to believe that it might be an installation problem
image

:confused:

The samples files work properly, but my particular scrip just turns red.

200622_Fins.3dm (40.0 KB) 200622_Fins.gh (42.0 KB)

Here you go sir.

I tried it in another computer and it still didnt work

I opened your model without any OpenNest errors and after flattening the Geo input the nesting seems fine. Is this the result you are after?

It is, i am hoping to have them labled as well, but i keep getting the same error

Here is the model which worked on my laptop, give it a go. If you still have problems I would suggest to dig deeper and maybe re-install the plugin.

200622_Fins.gh (51.6 KB)

That file still doesn’t work, I will try re-installing it thank you!

I installed OpenNest 1.2 and it still gives me an error.

I Unlocked the file and the Sample files work fine

I don’t know if it matters but i do get this error