OffsetSrf problem with small radius near the surfaces' edges

Hello,

I have one polysurface and I use OffsetSrf command to make a solid plastic shape. Because the radius is very small the command doesn’t work well as I expected. I used BlendSrf to match two surfaces into one polysurface.



How can I make smooth edges of my solid? I tried to use fillet but it didn’t work.

What do I wrong? Thanks for advices.


Dear Jarmark

it is a geometric problem - i assume without looking at the .3dm ( you might want to post the .3dm file for future problems)
I think the local Radius (red Arc) is smaller then your offset-Distance.
so the offset is somehow self-intersecting at the point marked cyan.

you have to make sure, that your entire surface has no minimal Radius less then the desired offset.

you might check with _curvatureAnalysis -> min Radius (adjust the mesh !!!)

so you have to redesign the Blend-Surfaces.

hope that helps

good luck

Tom

1 Like

Hi @Tom_

You’re right. Radius is too small. I can redesign the curve and then produce polysurface and give it proper offset. Is there any other possibility to set fillet to that solid shape without recreating it from scratch?

Two planes are the main problem because they are not parallel. In this case blend option must be used.

spojler.3dm (857.7 KB)

depends a bit on the purpose, you will use the surfaces for - just for rendering or for fabrication…
The most proper approach would be, that the initial Surfaces-Design / Intention is already considering the later offset.
You can also piecewise offset single surfaces, correct self-intersecting results or replace them, … , trim and join.
best.
t.

1 Like

In such cases, it is a geometric problem if you want to keep a bend, (Rhino can not handle self-intersections), but it can be resolved by better handling the intersection (eliminating the curvature though).

1 Like

Ok. I will use OffsetSrf without radius and then apply radius by FilletEdge or BlendSrf.

What is the simplest way to create solid from two parallel surfaces? I tried Cap with no results. Should I manually create new planes then manually trim and join everything into one piece? If model doesn’t contain naked edges it means that is a solid?

check those commands:
connect the 2 Surfaces with
_line (or multiple lines
then
_sweep2

also:
_blendSrf with G0
_loft
_edgeSrf
_planarSrf
_srfPt

yes - in addition to above approaches

Yes.
closed Surface, closed Polysurface = Solid in Rhino-Termology

check
_Dir
_showEdges
_what

if you want more general input or learning resources i recommend
https://www.rhino3d.com/tutorials
-> Level 1/2 Manual

best

t

1 Like

Great into! Thank you @Tom_!