Nothing to Undo

There are similar posts, but no answers on the forum. Starting a new thread, hoping to resolve the issue. From time to time, ‘undo’ doesn’t work. It shows ‘nothing to undo.’ I even increased Undo Max memory used to 5000 mb, but I still get ‘nothing to undo.’ I have to close and open Rhino again to be able to undo. I also wonder if it has to do anything with the file size? It’s big at 500mb (exported from Revit, using Grasshopper with Inside.Revit–but using it in Rhino 6 to use Enscape for rendering)

The below is System info.

Rhino 6 SR27 2020-6-24 (Rhino 6, 6.27.20176.05001, Git hash:master @ ba2c30de00be5a8b210bc297715204e941911799)
License type: Commercial, build 2020-06-24
License details: Cloud Zoo. In use by: L Song (NELSON)

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: WS18-2UA8251ZF6

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1070 Ti (NVidia) Memory: 8GB, Driver date: 12-6-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 441.66

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-6-2019
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.27.20176.5001
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.27.20176.5001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.27.20176.5001
C:\Program Files\Enscape\Bin64\Enscape.Rhino6.Plugin.dll “Enscape.Rhino6.Plugin” 0.0.20090.750
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.27.20176.5001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\BlockEdit.rhp “BlockEdit” 6.27.20176.5001
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

I don’t think is related but updating the video driver could help

Hello - if you open Rhino, make a box and Undo, does that much work? If so, what is the operation you are trying to undo when it fails?


it doesn’t matter what operation. When I run into ‘nothing to undo,’ I try simplest operations, such as draw lines or making a box. It still shows ‘nothing to undo’ until I close and reopen Rhino.

Hello - the question is, dopes this happen in a new session of Rhino and I think the answer is no. You get X amount of memory for Undo. If you have a massive model and you select everything and move it, there is a good chance that this one operation will eat up the available Undo memory. You can undo hundreds of lines, but maybe not even one large operation. So, what is eating up your undo stack, is what you’s want to figure out - assuming everything is in fact working as designed. The ClearUndo command may be of some use. That will toss out what has been ‘recorded’ and clear the undo pile.


will try clearundo. Is there a setting to automatically ‘clearundo’? I thought after the set ram limitation, it’d clear old undo memory so that new ones can keep working.

Strange. The file I’m working on is only 8mb, but I also started getting nothing to undo. I had to look up this post to remember to use clear undo. It works after the command. I don’t see this problem with other programs.

Why couldn’t Rhino just delete the oldest memories one by one if it runs out of memory so that the user can always have access to undo the latest command?

That’s exactly what it does. However, depending on what you are doing, one single operation could take up the entire amount of memory allocated to Undo - which would shove all the others off the bottom of the stack… What is your Undo memory allocation set at?


I allocated 32GB. When I first posted the problem, I had it at 5GB. Still got nothing to undo.

Hello- the number should probably not be more than 10% of your system RAM. Please post or send to a file that shows the problem and describe exactly the command or process that will not allow Undo. Please include a link back to this topic in your comments.
Please also confirm that in a new file, making simple objects and moving them or otherwise editing them works as expected with Undo.