Nothing to Undo Bug?

I was using Enscape, granted, but closed it.

Now any operation I make can’t be undone… anyone else?

image

I have no idea how Enscape might be involved so I’ll ignore it.
Rhino sets aside a limited amount of memory for the Undo stack.
If you do a bunch a simple operations that don’t use much memory; like drawing lines and circles, then that memory can hold a huge number of Undos.
If you do an operation that uses a lot of memory; like a Mesh Boolean, there may not be enough memory to hold even one Undo.

The amount of memory set aside for this can be found in Options > General 1024 Mb is the default. Remember that memory you carve out for Undo, is not available for modeling or anything else.

Maybe because I was using Enscape and other apps consuming memory my PC ran out of it for undo steps? Is that possible?

At one point not even a simple move was recorded.

As a test, I would close and restart Rhino, then try some basic stuff like curves, etc. in a new file
Then see if Undo is still working.
If it is initialize Enscape and see if that kills Undo.

Hi, I ran into this again today.

I think I have memory left.

image

I have this setting like so:

Have you tried increasing the Undo memory setting, to say 2048, and see if the keeps you working.

If you have 24GB of free ram, sounds like you can give some more memory to the Undo buffer.

1 Like

Yup will do that and check. Thank you.

1 Like

Hi I have the same bug on Mac V8, but there is no undo setting in Preferences/General. It happend just after I edited and assigned some rhino materials so it might be connected to something else than ram? Video and SystemInfo is attached.

After the restart of rhino the bug is gone, but my model is messed up since i can’t undo previous transformations.

Please fix it, this never happend to me before. Not even in WIP versions!!


SystemInfo.txt (5.1 KB)

I experience thus on a regular basis in Rhino 8. Mine is even more strange; as it will go…

Nothing to Undo
Nothing to Undo 
Nothing to Undo
<Undoes Something>
Nothing to Undo

Maybe this command has turned into a Hit and Miss algorithm nowadays.